summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-12-31 15:14:37 +0700
committerKonstantin Shalygin2018-12-31 15:14:37 +0700
commitde5d648d668a98b1329c924c984b00a3c20a19c0 (patch)
tree926949f423a08cc2d904ec362f247414b309e780
parent123b59304195f444a0feeb6922919434dcbea4ed (diff)
downloadaur-de5d648d668a98b1329c924c984b00a3c20a19c0.tar.gz
Bump to 6.0.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
-rw-r--r--frr_6.0_systemd_arch.patch303
3 files changed, 17 insertions, 334 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 808235705280..61a7c5bc3b95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Oct 25 13:07:34 UTC 2018
+# Mon Dec 31 08:14:29 UTC 2018
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.
- pkgver = 6.0
- pkgrel = 2
+ pkgver = 6.0.1
+ pkgrel = 1
url = https://frrouting.org/
arch = any
license = GPL2
@@ -20,6 +20,7 @@ pkgbase = frr
depends = readline
depends = ncurses
depends = perl
+ depends = pam
depends = json-c
depends = net-snmp
depends = rtrlib
@@ -28,14 +29,12 @@ pkgbase = frr
conflicts = quagga
conflicts = babeld
conflicts = quagga_cumulus
- source = https://github.com/FRRouting/frr/archive/frr-6.0.tar.gz
+ source = https://github.com/FRRouting/frr/archive/frr-6.0.1.tar.gz
source = frr.sysusers
source = frr.tmpfiles
- source = frr_6.0_systemd_arch.patch
- sha256sums = 3835d87e2329c1c08d1b2657312c0ba0155d8f442c338d60f0ddb51090f2f182
+ sha256sums = 5fa2defebf00fb457edaa3cc39a63534b081526c00a3aeafc569caa7fc300cd1
sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
- sha256sums = 9d98a0b5d7016cb66fe3cbec234f70327f0a961de47f7eae39a5bd4477b072ce
pkgname = frr
diff --git a/PKGBUILD b/PKGBUILD
index 0eb148c8aee3..81edc0b414b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,26 @@
# Contributor: Shalygin Konstantin <k0ste@k0ste.ru>
pkgname='frr'
-pkgver='6.0'
-pkgrel='2'
+pkgver='6.0.1'
+pkgrel='1'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.'
arch=('any')
url="https://frrouting.org/"
license=('GPL2')
-depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'json-c' 'net-snmp' 'rtrlib')
+depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'pam' 'json-c' 'net-snmp' 'rtrlib')
makedepends=('patch' 'gcc' 'net-snmp' 'bison' 'c-ares' 'perl-xml-libxml' 'python-sphinx' 'python-pytest')
conflicts=('quagga' 'babeld' 'quagga_cumulus')
provides=('quagga' 'quagga_cumulus')
source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
- "${pkgname}.tmpfiles"
- "${pkgname}_6.0_systemd_arch.patch")
-sha256sums=('3835d87e2329c1c08d1b2657312c0ba0155d8f442c338d60f0ddb51090f2f182'
+ "${pkgname}.tmpfiles")
+sha256sums=('5fa2defebf00fb457edaa3cc39a63534b081526c00a3aeafc569caa7fc300cd1'
'9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
- '6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
- '9d98a0b5d7016cb66fe3cbec234f70327f0a961de47f7eae39a5bd4477b072ce')
+ '6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- # https://github.com/FRRouting/frr/issues/1422
- patch -p1 -i "${srcdir}/${pkgname}_6.0_systemd_arch.patch"
-
autoreconf -fvi
./configure \
--prefix="/usr" \
@@ -34,7 +29,7 @@ prepare() {
--sysconfdir="/etc/${pkgname}" \
--localstatedir="/run/${pkgname}" \
--enable-exampledir="/etc/${pkgname}" \
- --disable-watchfrr \
+ --with-libpam \
--enable-snmp="agentx" \
--enable-multipath=256 \
--enable-user="${pkgname}" \
@@ -61,23 +56,15 @@ check() {
package() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -Dm0644 "bgpd/BGP4-MIB.txt" "${pkgdir}/usr/share/snmp/mibs/BGP4-MIB.txt"
- install -Dm0644 "eigrpd/EIGRP-MIB.txt" "${pkgdir}/usr/share/snmp/mibs/EIGRP-MIB.txt"
- install -Dm0644 "ospf6d/OSPFv3-MIB.txt" "${pkgdir}/usr/share/snmp/mibs/OSPFv3-MIB.txt"
- install -Dm0644 "ospfd/OSPF-MIB.txt" "${pkgdir}/usr/share/snmp/mibs/OSPF-MIB.txt"
- install -Dm0644 "ospfd/OSPF-TRAP-MIB.txt" "${pkgdir}/usr/share/snmp/mibs/OSPF-TRAP-MIB.txt"
- install -Dm0644 "ripd/RIPv2-MIB.txt" "${pkgdir}/usr/share/snmp/mibs/RIPv2-MIB.txt"
cd "redhat"
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
+ sed -ri 's|/usr/lib/frr/|/usr/bin/|g' "${pkgname}.service"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
-
- for d in babeld bgpd bfdd eigrpd isisd ldpd nhrpd ospf6d ospfd ospfd-instance@ pbrd pimd ripd ripngd staticd zebra; do
- install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
- done
-
+ install -Dm0644 "daemons" "${pkgdir}/etc/frr/daemons"
+ install -Dm0644 "${pkgname}.pam" "${pkgdir}/etc/pam.d/${pkgname}"
+ install -Dm0644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm0644 "${srcdir}/${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
install -Dm0644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
- rm -rfv "${pkgdir}/usr/bin/${pkgname}" "${pkgdir}/usr/bin/${pkgname}-reload.py"
chown -R 177:177 "${pkgdir}/etc/frr"
}
diff --git a/frr_6.0_systemd_arch.patch b/frr_6.0_systemd_arch.patch
deleted file mode 100644
index a05d313fa33d..000000000000
--- a/frr_6.0_systemd_arch.patch
+++ /dev/null
@@ -1,303 +0,0 @@
-diff -Naupr frr-frr-6.0_orig/redhat/babeld.service frr-frr-6.0/redhat/babeld.service
---- frr-frr-6.0_orig/redhat/babeld.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/babeld.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=Babel routing daemon
-+Documentation=man:babeld(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/babeld.pid
-+ExecStart=/usr/bin/babeld -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/bfdd.service frr-frr-6.0/redhat/bfdd.service
---- frr-frr-6.0_orig/redhat/bfdd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/bfdd.service 2018-10-12 10:05:33.009496639 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=Communication failure detection daemon
-+Documentation=man:bfdd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/bfdd.pid
-+ExecStart=/usr/bin/bfdd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/bgpd.service frr-frr-6.0/redhat/bgpd.service
---- frr-frr-6.0_orig/redhat/bgpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/bgpd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=BGP routing daemon
-+Documentation=man:bgpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/bgpd.pid
-+ExecStart=/usr/bin/bgpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/eigrpd.service frr-frr-6.0/redhat/eigrpd.service
---- frr-frr-6.0_orig/redhat/eigrpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/eigrpd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=EIGRP routing daemon
-+Documentation=man:eigrpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/eigrpd.pid
-+ExecStart=/usr/bin/eigrpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/isisd.service frr-frr-6.0/redhat/isisd.service
---- frr-frr-6.0_orig/redhat/isisd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/isisd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=IS-IS routing daemon
-+Documentation=man:isis(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/isisd.pid
-+ExecStart=/usr/bin/isisd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/ldpd.service frr-frr-6.0/redhat/ldpd.service
---- frr-frr-6.0_orig/redhat/ldpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/ldpd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=LDP engine
-+Documentation=man:ldpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ldpd.pid
-+ExecStart=/usr/bin/ldpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/nhrpd.service frr-frr-6.0/redhat/nhrpd.service
---- frr-frr-6.0_orig/redhat/nhrpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/nhrpd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=NHRP daemon
-+Documentation=man:nhrpd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/nhrpd.pid
-+ExecStart=/usr/bin/nhrpd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/ospf6d.service frr-frr-6.0/redhat/ospf6d.service
---- frr-frr-6.0_orig/redhat/ospf6d.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/ospf6d.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=OSPF routing daemon for IPv6
-+Documentation=man:ospfd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ospf6d.pid
-+ExecStart=/usr/bin/ospf6d -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/ospfd-instance@.service frr-frr-6.0/redhat/ospfd-instance@.service
---- frr-frr-6.0_orig/redhat/ospfd-instance@.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/ospfd-instance@.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=OSPF routing daemon instance %i
-+Documentation=man:ospfd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service ospfd.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ospfd-%i.pid
-+ExecStart=/usr/bin/ospfd -n %i -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/ospfd.service frr-frr-6.0/redhat/ospfd.service
---- frr-frr-6.0_orig/redhat/ospfd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/ospfd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=OSPF routing daemon
-+Documentation=man:ospfd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ospfd.pid
-+ExecStart=/usr/bin/ospfd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/pbrd.service frr-frr-6.0/redhat/pbrd.service
---- frr-frr-6.0_orig/redhat/pbrd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/pbrd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=PBR routing daemon
-+Documentation=man:pbrd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/pbrd.pid
-+ExecStart=/usr/bin/pbrd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/pimd.service frr-frr-6.0/redhat/pimd.service
---- frr-frr-6.0_orig/redhat/pimd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/pimd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,14 @@
-+[Unit]
-+Description=PIM multicast routing engine
-+Documentation=man:pimd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/pimd.pid
-+ExecStart=/usr/bin/pimd -d
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/ripd.service frr-frr-6.0/redhat/ripd.service
---- frr-frr-6.0_orig/redhat/ripd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/ripd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=RIP routing daemon
-+Documentation=man:ripd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ripd.pid
-+ExecStart=/usr/bin/ripd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/ripngd.service frr-frr-6.0/redhat/ripngd.service
---- frr-frr-6.0_orig/redhat/ripngd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/ripngd.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=RIP routing daemon for IPv6
-+Documentation=man:ripngd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/ripngd.pid
-+ExecStart=/usr/bin/ripngd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/staticd.service frr-frr-6.0/redhat/staticd.service
---- frr-frr-6.0_orig/redhat/staticd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/staticd.service 2018-10-12 10:13:47.017305494 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=Zebra daemon responsible for management of static routes
-+Documentation=man:staticd(8) man:zebra(8)
-+BindTo=zebra.service
-+After=network.target zebra.service
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/staticd.pid
-+ExecStart=/usr/bin/staticd -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target
-diff -Naupr frr-frr-6.0_orig/redhat/zebra.service frr-frr-6.0/redhat/zebra.service
---- frr-frr-6.0_orig/redhat/zebra.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr-frr-6.0/redhat/zebra.service 2018-10-12 09:58:16.424665052 +0700
-@@ -0,0 +1,15 @@
-+[Unit]
-+Description=GNU Zebra routing manager
-+Documentation=man:zebra(8)
-+After=network.target
-+
-+[Service]
-+Type=forking
-+PIDFile=/run/frr/zebra.pid
-+ExecStartPre=/usr/bin/ip route flush proto zebra
-+ExecStart=/usr/bin/zebra -d
-+ExecReload=/bin/kill -HUP $MAINPID
-+Restart=on-abort
-+
-+[Install]
-+WantedBy=multi-user.target