summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2017-10-17 19:36:44 +0700
committerKonstantin Shalygin2017-10-17 20:12:35 +0700
commit7bb51ad794783c245ce332c98534e074ab3e3778 (patch)
tree21478a5ebf1307f7db9201ea9cf4b237cc6b2239
parent13e80d20e288da163c0749937002f674a5e835de (diff)
downloadaur-7bb51ad794783c245ce332c98534e074ab3e3778.tar.gz
Fixed source of frr, added nhrpd.service, add /etc/frr
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--frr.sysusers3
-rw-r--r--frr_3.0_systemd_arch.patch (renamed from frr_systemd_arch.patch)79
4 files changed, 67 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6660518421c2..183354cf9e67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Oct 17 11:55:26 UTC 2017
+# Tue Oct 17 13:12:11 UTC 2017
pkgbase = frr
pkgdesc = FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.
pkgver = 3.0
- pkgrel = 1
+ pkgrel = 2
url = https://frrouting.org/
arch = any
license = GPL2
@@ -22,14 +22,14 @@ pkgbase = frr
provides = quagga_cumulus
conflicts = quagga
conflicts = quagga_cumulus
- source = https://frrouting.org//archive/frr-3.0.tar.gz
+ source = https://github.com/FRRouting/frr/archive/frr-3.0.tar.gz
source = frr.sysusers
source = frr.tmpfiles
- source = frr_systemd_arch.patch
+ source = frr_3.0_systemd_arch.patch
sha256sums = 9335c83c2c0a21e64b4e64a130ee95c1f90d76103cff05e816f452a8ba0603d9
- sha256sums = d3eb1648c018d37e0327dad07ba42f08dfe610838d444d454ca4ab38ece1e8c4
+ sha256sums = 9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e
sha256sums = 6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89
- sha256sums = 85f3396b49e3a3c84c344ee548bb2d185152356ca8a7bdcb5a850dc2e477665d
+ sha256sums = caf47e9efa48678121437f41aaa0e8b1bf3f212539082b2b07e0de6b6b9c7ba3
pkgname = frr
diff --git a/PKGBUILD b/PKGBUILD
index c8dcfee1051f..f6ea1ef96f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='frr'
pkgver='3.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='FRRouting (quagga fork) supports BGP4, OSPFv2, OSPFv3, ISIS, RIP, RIPng, PIM, LDP, NHRP and EIGRP.'
arch=('any')
url="https://frrouting.org/"
@@ -12,18 +12,18 @@ depends=('libcap' 'libnl' 'readline' 'ncurses' 'perl' 'json-c' 'net-snmp')
makedepends=('patch' 'gcc' 'net-snmp' 'json-c')
conflicts=('quagga' 'quagga_cumulus')
provides=('quagga' 'quagga_cumulus')
-source=("${url}/archive/${pkgname}-${pkgver}.tar.gz"
+source=("https://github.com/FRRouting/${pkgname}/archive/${pkgname}-${pkgver}.tar.gz"
"${pkgname}.sysusers"
"${pkgname}.tmpfiles"
- "${pkgname}_systemd_arch.patch")
+ "${pkgname}_3.0_systemd_arch.patch")
sha256sums=('9335c83c2c0a21e64b4e64a130ee95c1f90d76103cff05e816f452a8ba0603d9'
- 'd3eb1648c018d37e0327dad07ba42f08dfe610838d444d454ca4ab38ece1e8c4'
+ '9371cc0522d13621c623b5da77719052bdebdceb7ffdbdc06fc32a2f07118e7e'
'6f8dd86ef9c600763faead3052908531e8dc8ef67058e6f7f8da01bf0fe4eb89'
- '85f3396b49e3a3c84c344ee548bb2d185152356ca8a7bdcb5a850dc2e477665d')
+ 'caf47e9efa48678121437f41aaa0e8b1bf3f212539082b2b07e0de6b6b9c7ba3')
prepare() {
cd "${srcdir}/${pkgname}-${pkgname}-${pkgver}"
- patch -p1 -i "${srcdir}/${pkgname}_systemd_arch.patch"
+ patch -p1 -i "${srcdir}/${pkgname}_3.0_systemd_arch.patch"
autoreconf -fvi
./configure \
@@ -31,7 +31,7 @@ prepare() {
--sbindir="/usr/bin" \
--sysconfdir="/etc/${pkgname}" \
--localstatedir="/run/${pkgname}" \
- --enable-exampledir="/usr/share/doc/${pkgname}/examples" \
+ --enable-exampledir="/etc/${pkgname}" \
--enable-ldpd \
--enable-nhrpd \
--disable-bgp-vnc \
@@ -66,7 +66,7 @@ package() {
sed -ri 's|/var/run/frr|/run/frr|g' "${pkgname}.logrotate"
install -Dm0644 "${pkgname}.logrotate" "${pkgdir}/etc/logrotate.d/${pkgname}"
- for d in zebra ripd ripngd bgpd ospfd ospfd-instance@ ospf6d isisd pimd ldpd; do
+ for d in zebra ripd ripngd bgpd ospfd ospfd-instance@ ospf6d isisd pimd ldpd nhrpd; do
install -Dm0644 ${d}.service "${pkgdir}/usr/lib/systemd/system/${d}.service"
done
@@ -74,4 +74,6 @@ package() {
install -Dm0644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
rm -rfv "${pkgdir}/usr/bin/${pkgname}"
rm -rfv "${pkgdir}/usr/bin/${pkgname}-reload.py"
+ # frr:frrvty
+ chown -R 177:178 "${pkgdir}/etc/frr"
}
diff --git a/frr.sysusers b/frr.sysusers
index 47ebe789b060..676a75278b22 100644
--- a/frr.sysusers
+++ b/frr.sysusers
@@ -1,4 +1,5 @@
# Create frr user
-u frr - - /run/frr
+u frr 177 - /run/frr
# Create frrvty group and add frr user to this group
+g frrvty 178
m frr frrvty
diff --git a/frr_systemd_arch.patch b/frr_3.0_systemd_arch.patch
index 20f2b58d82ad..2d49be4056d7 100644
--- a/frr_systemd_arch.patch
+++ b/frr_3.0_systemd_arch.patch
@@ -1,6 +1,6 @@
-diff -Naupr frr_orig/redhat/bgpd.service frr/redhat/bgpd.service
---- frr_orig/redhat/bgpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/bgpd.service 2017-02-04 21:44:22.399171740 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/bgpd.service frr-frr-3.0/redhat/bgpd.service
+--- frr-frr-3.0_orig/redhat/bgpd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/bgpd.service 2017-10-17 19:25:16.036060790 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=BGP routing daemon
@@ -17,9 +17,9 @@ diff -Naupr frr_orig/redhat/bgpd.service frr/redhat/bgpd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/isisd.service frr/redhat/isisd.service
---- frr_orig/redhat/isisd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/isisd.service 2017-02-04 21:44:28.029195379 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/isisd.service frr-frr-3.0/redhat/isisd.service
+--- frr-frr-3.0_orig/redhat/isisd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/isisd.service 2017-10-17 19:25:16.036060790 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=IS-IS routing daemon
@@ -36,9 +36,9 @@ diff -Naupr frr_orig/redhat/isisd.service frr/redhat/isisd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/ldpd.service frr/redhat/ldpd.service
---- frr_orig/redhat/ldpd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/ldpd.service 2017-02-04 21:44:14.649139198 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/ldpd.service frr-frr-3.0/redhat/ldpd.service
+--- frr-frr-3.0_orig/redhat/ldpd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/ldpd.service 2017-10-17 19:25:16.036060790 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=LDP engine
@@ -55,9 +55,28 @@ diff -Naupr frr_orig/redhat/ldpd.service frr/redhat/ldpd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/ospf6d.service frr/redhat/ospf6d.service
---- frr_orig/redhat/ospf6d.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/ospf6d.service 2017-02-04 21:44:34.375888694 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/nhrpd.service frr-frr-3.0/redhat/nhrpd.service
+--- frr-frr-3.0_orig/redhat/nhrpd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/nhrpd.service 2017-10-17 19:31:33.177858913 +0700
+@@ -0,0 +1,15 @@
++[Unit]
++Description=NHRP daemon
++Documentation=man:nhrpd(8) man:zebra(8)
++BindTo=zebra.service
++After=network.target zebra.service
++
++[Service]
++Type=forking
++PIDFile=/run/frr/nhrpd.pid
++ExecStart=/usr/bin/nhrpd -d
++ExecReload=/bin/kill -HUP $MAINPID
++Restart=on-abort
++
++[Install]
++WantedBy=multi-user.target
+diff -Naupr frr-frr-3.0_orig/redhat/ospf6d.service frr-frr-3.0/redhat/ospf6d.service
+--- frr-frr-3.0_orig/redhat/ospf6d.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/ospf6d.service 2017-10-17 19:25:16.036060790 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=OSPF routing daemon for IPv6
@@ -74,9 +93,9 @@ diff -Naupr frr_orig/redhat/ospf6d.service frr/redhat/ospf6d.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/ospfd-instance@.service frr/redhat/ospfd-instance@.service
---- frr_orig/redhat/ospfd-instance@.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/ospfd-instance@.service 2017-02-04 21:44:38.465905867 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/ospfd-instance@.service frr-frr-3.0/redhat/ospfd-instance@.service
+--- frr-frr-3.0_orig/redhat/ospfd-instance@.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/ospfd-instance@.service 2017-10-17 19:25:16.036060790 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=OSPF routing daemon instance %i
@@ -93,9 +112,9 @@ diff -Naupr frr_orig/redhat/ospfd-instance@.service frr/redhat/ospfd-instance@.s
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/ospfd.service frr/redhat/ospfd.service
---- frr_orig/redhat/ospfd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/ospfd.service 2017-02-04 21:44:41.415918254 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/ospfd.service frr-frr-3.0/redhat/ospfd.service
+--- frr-frr-3.0_orig/redhat/ospfd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/ospfd.service 2017-10-17 19:25:16.039394137 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=OSPF routing daemon
@@ -112,9 +131,9 @@ diff -Naupr frr_orig/redhat/ospfd.service frr/redhat/ospfd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/pimd.service frr/redhat/pimd.service
---- frr_orig/redhat/pimd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/pimd.service 2017-02-04 21:45:14.026054971 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/pimd.service frr-frr-3.0/redhat/pimd.service
+--- frr-frr-3.0_orig/redhat/pimd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/pimd.service 2017-10-17 19:25:16.039394137 +0700
@@ -0,0 +1,14 @@
+[Unit]
+Description=PIM multicast routing engine
@@ -130,9 +149,9 @@ diff -Naupr frr_orig/redhat/pimd.service frr/redhat/pimd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/ripd.service frr/redhat/ripd.service
---- frr_orig/redhat/ripd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/ripd.service 2017-02-04 21:45:16.656065993 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/ripd.service frr-frr-3.0/redhat/ripd.service
+--- frr-frr-3.0_orig/redhat/ripd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/ripd.service 2017-10-17 19:25:16.039394137 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=RIP routing daemon
@@ -149,9 +168,9 @@ diff -Naupr frr_orig/redhat/ripd.service frr/redhat/ripd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/ripngd.service frr/redhat/ripngd.service
---- frr_orig/redhat/ripngd.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/ripngd.service 2017-02-04 21:47:08.866535951 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/ripngd.service frr-frr-3.0/redhat/ripngd.service
+--- frr-frr-3.0_orig/redhat/ripngd.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/ripngd.service 2017-10-17 19:25:16.039394137 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=RIP routing daemon for IPv6
@@ -168,9 +187,9 @@ diff -Naupr frr_orig/redhat/ripngd.service frr/redhat/ripngd.service
+
+[Install]
+WantedBy=multi-user.target
-diff -Naupr frr_orig/redhat/zebra.service frr/redhat/zebra.service
---- frr_orig/redhat/zebra.service 1970-01-01 07:00:00.000000000 +0700
-+++ frr/redhat/zebra.service 2017-02-04 21:47:15.876565302 +0700
+diff -Naupr frr-frr-3.0_orig/redhat/zebra.service frr-frr-3.0/redhat/zebra.service
+--- frr-frr-3.0_orig/redhat/zebra.service 1970-01-01 07:00:00.000000000 +0700
++++ frr-frr-3.0/redhat/zebra.service 2017-10-17 19:25:16.039394137 +0700
@@ -0,0 +1,15 @@
+[Unit]
+Description=GNU Zebra routing manager