summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2015-04-30 01:19:35 -0700
committerMike Swanson2015-04-30 01:19:35 -0700
commit440e03b34fd600cf6422eff2fd12d780dc428da2 (patch)
tree918a4c6a579f30890e12bd749877ede917ae253d
parentde7033c7ecfe8caab9877a3a04d81e48903e9478 (diff)
downloadaur-440e03b34fd600cf6422eff2fd12d780dc428da2.tar.gz
Update fs2_open to 3.7.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rwxr-xr-xfs2_open2
-rw-r--r--increase_joy_buttons_fixed.patch17
-rw-r--r--options2
5 files changed, 22 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a13895f5211d..18e453fc423e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fs2_open
pkgdesc = An enhancement of the FreeSpace 2 engine
- pkgver = 3.7.2~rc5
+ pkgver = 3.7.2
pkgrel = 1
epoch = 1
url = http://scp.indiegames.us
@@ -19,16 +19,16 @@ pkgbase = fs2_open
depends = openal
depends = sdl
optdepends = fs2_open-mediavps: extensive audiovisual enhancements
- source = http://swc.fs2downloads.com/builds/fs2_open_3_7_2_RC5_src.tgz
+ source = http://swc.fs2downloads.com/builds/fs2_open_3_7_2_src.tgz
source = fs2_open
source = fs2_open.desktop
source = increase_joy_buttons_fixed.patch
source = options
- sha256sums = a68ed22e2868e987c7ab5167207a9da3ab192c0efa32c49f6f5ab364609d6090
- sha256sums = 6b79b1989692cd0e03106403d2c96a70d3ef6f75f488142ece6a4db9acd260c9
+ sha256sums = 3e266eb84a4c289e21cb08f3bde8e6e6e0d1bf97953e8cc06db1a179cc127ea2
+ sha256sums = c978c91ced574a0904a883d41c72248796e0cf50a0c5e06bc5f890d92bb244c1
sha256sums = cac8914fb96eb4f09d8dec0005ccb3626499ab9f3f4c5f64c11bd8d2e913e372
- sha256sums = b5d6574fbb6cb84294502140c74310178f6d588092ffe33692274d95a882096b
- sha256sums = 6e8148aea5d23658e74a2893652de8889af45d542c079d086b8fd586c8b73229
+ sha256sums = 015b57bafd327e7b549a09e0a03619fabdc7be63afe88860fbe0f4114dc81731
+ sha256sums = c593dacd19705f1aaf23170d7b65b4621945200d3a496e256f77e3f1f0279741
pkgname = fs2_open
diff --git a/PKGBUILD b/PKGBUILD
index d75a2bc3e398..8f73f2ee285d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,8 +12,8 @@
# Check the AUR package 'fs2_open-data' for details.
pkgname=fs2_open
-pkgver=3.7.2~rc5
-_pkgver=3_7_2_RC5 # Upstream's url/dirs ...
+pkgver=3.7.2
+_pkgver=3_7_2 # Upstream's url/dirs ...
pkgrel=1
epoch=1
pkgdesc="An enhancement of the FreeSpace 2 engine"
@@ -29,11 +29,11 @@ source=(http://swc.fs2downloads.com/builds/fs2_open_${_pkgver}_src.tgz
'fs2_open.desktop'
'increase_joy_buttons_fixed.patch'
'options')
-sha256sums=('a68ed22e2868e987c7ab5167207a9da3ab192c0efa32c49f6f5ab364609d6090'
- '6b79b1989692cd0e03106403d2c96a70d3ef6f75f488142ece6a4db9acd260c9'
+sha256sums=('3e266eb84a4c289e21cb08f3bde8e6e6e0d1bf97953e8cc06db1a179cc127ea2'
+ 'c978c91ced574a0904a883d41c72248796e0cf50a0c5e06bc5f890d92bb244c1'
'cac8914fb96eb4f09d8dec0005ccb3626499ab9f3f4c5f64c11bd8d2e913e372'
- 'b5d6574fbb6cb84294502140c74310178f6d588092ffe33692274d95a882096b'
- '6e8148aea5d23658e74a2893652de8889af45d542c079d086b8fd586c8b73229')
+ '015b57bafd327e7b549a09e0a03619fabdc7be63afe88860fbe0f4114dc81731'
+ 'c593dacd19705f1aaf23170d7b65b4621945200d3a496e256f77e3f1f0279741')
prepare() {
cd "$srcdir/${pkgname}_${_pkgver}"
diff --git a/fs2_open b/fs2_open
index c3a7cf406275..d27184925acd 100755
--- a/fs2_open
+++ b/fs2_open
@@ -8,4 +8,4 @@ fi
cd /opt/fs2_open
-/opt/fs2_open/fs2_open_3.7.2_RC4 "$@" "$FS2OPTS"
+/opt/fs2_open/fs2_open_3.7.2 "$@" "$FS2OPTS"
diff --git a/increase_joy_buttons_fixed.patch b/increase_joy_buttons_fixed.patch
index f2a7d4326b79..e91c512cda2e 100644
--- a/increase_joy_buttons_fixed.patch
+++ b/increase_joy_buttons_fixed.patch
@@ -1,6 +1,6 @@
-diff -u -r fs2_open_3_7_2_RC4.orig/code/controlconfig/controlsconfigcommon.cpp fs2_open_3_7_2_RC4/code/controlconfig/controlsconfigcommon.cpp
---- fs2_open_3_7_2_RC4.orig/code/controlconfig/controlsconfigcommon.cpp 2014-08-15 10:07:55.000000000 -0700
-+++ fs2_open_3_7_2_RC4/code/controlconfig/controlsconfigcommon.cpp 2014-12-10 00:20:38.582592151 -0800
+diff -u -r fs2_open_3_7_2.orig/code/controlconfig/controlsconfigcommon.cpp fs2_open_3_7_2/code/controlconfig/controlsconfigcommon.cpp
+--- fs2_open_3_7_2.orig/code/controlconfig/controlsconfigcommon.cpp 2015-01-22 11:32:23.000000000 -0800
++++ fs2_open_3_7_2/code/controlconfig/controlsconfigcommon.cpp 2015-04-30 01:07:59.747265442 -0700
@@ -238,12 +238,23 @@
};
@@ -60,8 +60,8 @@ diff -u -r fs2_open_3_7_2_RC4.orig/code/controlconfig/controlsconfigcommon.cpp f
+ "Bouton 97", "Bouton 98", "Chapeau Arri\x8Are", "Chapeau Avant", "Chapeau Gauche", "Chapeau Droite"
};
- //! This is the text that is displayed on the screen for the keys a player selects
-@@ -346,7 +368,18 @@
+ char *Scan_code_text_polish[] = {
+@@ -397,7 +419,18 @@
"Button 13", "Button 14", "Button 15", "Button 16", "Button 17", "Button 18",
"Button 19", "Button 20", "Button 21", "Button 22", "Button 23", "Button 24",
"Button 25", "Button 26", "Button 27", "Button 28", "Button 29", "Button 30",
@@ -81,9 +81,9 @@ diff -u -r fs2_open_3_7_2_RC4.orig/code/controlconfig/controlsconfigcommon.cpp f
};
char **Scan_code_text = Scan_code_text_english;
-diff -u -r fs2_open_3_7_2_RC4.orig/code/io/joy.h fs2_open_3_7_2_RC4/code/io/joy.h
---- fs2_open_3_7_2_RC4.orig/code/io/joy.h 2009-06-20 01:08:20.000000000 -0700
-+++ fs2_open_3_7_2_RC4/code/io/joy.h 2014-12-10 00:16:17.319816830 -0800
+diff -u -r fs2_open_3_7_2.orig/code/io/joy.h fs2_open_3_7_2/code/io/joy.h
+--- fs2_open_3_7_2.orig/code/io/joy.h 2009-06-20 01:08:20.000000000 -0700
++++ fs2_open_3_7_2/code/io/joy.h 2015-04-30 01:07:59.747265442 -0700
@@ -12,7 +12,7 @@
#ifndef __JOY_H__
#define __JOY_H__
@@ -93,4 +93,3 @@ diff -u -r fs2_open_3_7_2_RC4.orig/code/io/joy.h fs2_open_3_7_2_RC4/code/io/joy.
#define JOY_NUM_HAT_POS 4
#define JOY_TOTAL_BUTTONS (JOY_NUM_BUTTONS + JOY_NUM_HAT_POS)
#define JOY_NUM_AXES 6
-Only in fs2_open_3_7_2_RC4/code/io: joy.h~
diff --git a/options b/options
index 5bc0745b1625..61de327f3443 100644
--- a/options
+++ b/options
@@ -10,4 +10,4 @@
# A lot of graphical and gameplay options are set via these flags - you should
# really take a look.
-FS2OPTS="" \ No newline at end of file
+FS2OPTS=""