summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Frei2015-12-08 22:09:12 +0100
committerJonas Frei2015-12-08 22:09:12 +0100
commit61befad1edf04c5eb2741c33080da39452a4cb36 (patch)
tree80958e329cc369210f3e4646ecfe7e0bc0bdab48
downloadaur-61befad1edf04c5eb2741c33080da39452a4cb36.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD51
-rw-r--r--fs2_open-git.install20
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90575078c934
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Tue Dec 8 21:08:53 UTC 2015
+pkgbase = fs2_open-git
+ pkgdesc = An enhancement of the original Freespace 2 engine - GIT version
+ pkgver = 3.7.3
+ pkgrel = 11334
+ url = http://scp.indiegames.us
+ install = fs2_open-git.install
+ arch = i686
+ arch = x86_64
+ license = custom:fs2_open
+ makedepends = git
+ depends = libjpeg
+ depends = libpng
+ depends = libtheora
+ depends = libvorbis
+ depends = lua51
+ depends = mesa
+ depends = openal
+ depends = sdl
+ provides = fs2_open
+ conflicts = fs2_open
+
+pkgname = fs2_open-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98e988a8dfaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: freijon <freijon@gmail.com>
+# Contributor: Lone_Wolf <lonewolf@xs4all.nl>, ZekeSulastin <zekesulastin@gmail.com>
+
+pkgname=fs2_open-git
+pkgver=3.7.3
+pkgrel=11334
+pkgdesc="An enhancement of the original Freespace 2 engine - GIT version"
+url="http://scp.indiegames.us"
+arch=('i686' 'x86_64')
+license=('custom:fs2_open')
+depends=('libjpeg' 'libpng' 'libtheora' 'libvorbis' 'lua51' 'mesa' 'openal' 'sdl')
+makedepends=('git')
+conflicts=('fs2_open')
+provides=('fs2_open')
+install=fs2_open-git.install
+
+_gitrep='https://github.com/scp-fs2open/fs2open.github.com.git'
+_pkg=fs2_open
+
+build()
+{
+ cd "$srcdir"
+ msg "Cloning git repository...."
+
+ git clone $_gitrep
+
+ msg "git clone done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_pkg-build"
+ cd "$srcdir/fs2open.github.com"
+
+ # Add --enable-debug to make a debug build. These are NOT meant for general play;
+ # only make a debug build if generating logs/bugreports. This is true even for
+ # these GIT builds, if you're using a mod that requires them.
+ LDFLAGS="-l:liblua.so.5.1 $LDFLAGS" CXXFLAGS="-I/usr/include/lua5.1 $CXXFLAGS" ./autogen.sh --enable-speech
+ make
+}
+
+package () {
+ cd "$srcdir/fs2open.github.com"
+
+ _commit_hash=`git rev-parse HEAD`
+ install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ if [[ -x code/fs2_open_3.7.3 ]]; then
+ install -D -m755 code/fs2_open_3.7.3 "$pkgdir/opt/fs2_open/fs2_open_3.7.3_$_commit_hash"
+ else
+ install -D -m755 code/fs2_open_3.7.3_DEBUG "$pkgdir/opt/fs2_open/fs2_open_3.7.3_DEBUG_$_commit_hash"
+ fi
+}
+
diff --git a/fs2_open-git.install b/fs2_open-git.install
new file mode 100644
index 000000000000..8756ab1f4160
--- /dev/null
+++ b/fs2_open-git.install
@@ -0,0 +1,20 @@
+post_install() {
+
+cat << EOF
+>>> This is the svn trunk version of fs2_open.
+>>>
+>>> Development Forum:
+>>> http://www.hard-light.net/forums/index.php?board=50.0
+>>>
+>>> This package contains only the engine binary for fs2_open.
+>>> In order to run fs2_open, you need the data files from the
+>>> retail Freespace 2 CDs or Good Old Games' installer.
+>>>
+>>> Check the AUR package 'fs2_open-data' for details.
+EOF
+
+}
+
+post_upgrade() {
+ post_install
+}