summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Mikhailov2021-03-15 07:35:15 +1000
committerKonstantin Mikhailov2021-03-15 07:35:15 +1000
commitfd93fa6b823122ae8c3d68ba67ed4771612cf695 (patch)
tree905c6074a00b81116e81ced7a9302383a6017fd8
downloadaur-fd93fa6b823122ae8c3d68ba67ed4771612cf695.tar.gz
Initial release
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..062234cad081
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fselect-bin
+ pkgdesc = Find files with SQL-like queries
+ pkgver = 0.7.3
+ pkgrel = 1
+ url = https://github.com/jhspetersson/fselect
+ arch = x86_64
+ license = MIT
+ provides = fselect
+ conflicts = fselect
+ source_x86_64 = https://github.com/jhspetersson/fselect/releases/download/0.7.3/fselect-x86_64-linux-musl.gz
+ source_x86_64 = https://raw.githubusercontent.com/jhspetersson/fselect/0.7.3/docs/fselect.1
+ source_x86_64 = https://raw.githubusercontent.com/jhspetersson/fselect/0.7.3/docs/usage.md
+ sha256sums_x86_64 = 9150470105824b0bfd284caa0029a7b22b9d149b30edaba5f3cc05d426a6db76
+ sha256sums_x86_64 = e7467281dc4479444cb33ef087877ff304367e653e6a0922dec64364f33b3c91
+ sha256sums_x86_64 = b61c2fafafed78e0cd863766ecd0c856ca05a342e7cd85d8b8898dfd769a44cb
+
+pkgname = fselect-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc51a6e034c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Konstantin Mikhailov <jtraub.devel@gmail.com>
+
+pkgname=fselect-bin
+_pkgname="${pkgname%-bin}"
+pkgver=0.7.3
+pkgrel=1
+pkgdesc='Find files with SQL-like queries'
+url="https://github.com/jhspetersson/${_pkgname}"
+license=('MIT')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+arch=('x86_64')
+
+source_x86_64=(
+ "${url}/releases/download/${pkgver}/${_pkgname}-x86_64-linux-musl.gz"
+ # man page
+ "https://raw.githubusercontent.com/jhspetersson/${_pkgname}/${pkgver}/docs/${_pkgname}.1"
+ # more detailed document on usage
+ "https://raw.githubusercontent.com/jhspetersson/${_pkgname}/${pkgver}/docs/usage.md"
+)
+
+sha256sums_x86_64=(
+ # bin pkg sum
+ '9150470105824b0bfd284caa0029a7b22b9d149b30edaba5f3cc05d426a6db76'
+ # man page sum
+ 'e7467281dc4479444cb33ef087877ff304367e653e6a0922dec64364f33b3c91'
+ # usage.md
+ 'b61c2fafafed78e0cd863766ecd0c856ca05a342e7cd85d8b8898dfd769a44cb'
+)
+
+
+package() {
+ install -Dm 755 "$srcdir/${_pkgname}-x86_64-linux-musl" "$pkgdir/usr/bin/${_pkgname}"
+
+ install -Dm 644 "$srcdir/${_pkgname}.1" "$pkgdir/usr/share/man/man1/${_pkgname}.1"
+ install -Dm 644 "$srcdir/usage.md" "$pkgdir/usr/share/doc/${_pkgname}/usage.md"
+}