summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Gilio2018-09-09 15:58:19 -0500
committerBrett Gilio2018-09-09 15:58:19 -0500
commit4766b5af8173ca3768d11ca3b827ca388c3654ef (patch)
tree3c68d0e699920d776ff202a612067312b6321e2d
parent2b9f78bf5233466db12f79e89e5b81e9e33e4f10 (diff)
downloadaur-4766b5af8173ca3768d11ca3b827ca388c3654ef.tar.gz
PKGBuild Revisions
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD19
2 files changed, 9 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2078ce7e4d4e..a128969aed4b 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = fsharp
pkgdesc = The F# Compiler, Core Library & Tools (F# Software Foundation Repository)
pkgver = 4.5.0
- pkgrel = 1
+ pkgrel = 2
url = http://fsharp.org/
arch = any
license = MIT
- makedepends = git
depends = mono
depends = msbuild-stable
- source = git+https://github.com/fsharp/fsharp/#commit=3de387432de8d11a89f99d1af87aa9ce194fe21b
- sha256sums = SKIP
+ source = fsharp-4.5.0.tar.gz::https://github.com/fsharp/fsharp/archive/4.5.0.tar.gz
+ sha256sums = 71be24bd4bac47fcad3f9e544c17f23fea9ebce3b47082720804f3f9f1b08f16
pkgname = fsharp
diff --git a/PKGBUILD b/PKGBUILD
index 867072b882e7..ed11a4cade65 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,22 @@
pkgname=fsharp
pkgver=4.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="The F# Compiler, Core Library & Tools (F# Software Foundation Repository)"
arch=('any')
url="http://fsharp.org/"
license=('MIT')
depends=('mono' 'msbuild-stable')
-makedepends=(git)
-_commit=3de387432de8d11a89f99d1af87aa9ce194fe21b # tags/4.5.0
-source=("git+https://github.com/fsharp/fsharp/#commit=$_commit")
-sha256sums=('SKIP')
-
-pkgver() {
- cd $pkgname
- git describe --tags | sed 's/-/+/g'
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fsharp/fsharp/archive/$pkgver.tar.gz")
+sha256sums=('71be24bd4bac47fcad3f9e544c17f23fea9ebce3b47082720804f3f9f1b08f16')
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
prefix=/usr
- make
+# make
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-$pkgver"
make prefix="/usr" DESTDIR="$pkgdir" install
}