summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2016-07-21 23:45:33 +0200
committerMort Yao2016-07-21 23:46:07 +0200
commitd1b9a60635bd5a1912cef306e0fb1e86c52a95a1 (patch)
treea4623da400fa9e7d93c5c47faa062702b59bc19b
parentef8e0f93f00dd64659a3b7668271d7aad0bbffdb (diff)
downloadaur-d1b9a60635bd5a1912cef306e0fb1e86c52a95a1.tar.gz
Update to 4.0.1.5-1
-rwxr-xr-x.SRCINFO12
-rw-r--r--Makefile124
-rwxr-xr-xPKGBUILD19
3 files changed, 144 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ca229985e8e..8ad3820b7d67 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Thu Jul 21 12:16:18 UTC 2016
+# Thu Jul 21 21:45:06 UTC 2016
pkgbase = fsharp
pkgdesc = The Open Edition of the F# compiler, core library and tools
- pkgver = 4.0.1.1
- pkgrel = 2
+ pkgver = 4.0.1.5
+ pkgrel = 1
url = http://fsharp.org/
arch = any
license = Apache
depends = mono>=4.0.3.20
- source = fsharp-4.0.1.1.tar.gz::https://github.com/fsharp/fsharp/archive/4.0.1.1.tar.gz
- md5sums = 2dd3cc2cf130615bc79ceb1b93141e2b
+ source = fsharp-4.0.1.5.tar.gz::https://github.com/fsharp/fsharp/archive/4.0.1.5.tar.gz
+ source = Makefile
+ md5sums = 5974b6df0aa6df01f153afadcbdc6061
+ md5sums = 72399b0b526807ff847d7d090344a36c
pkgname = fsharp
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..769ed580ec41
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,124 @@
+srcdir := <SRCDIR>/fsharp-4.0.1.5/src/fsharp/
+
+include <SRCDIR>/fsharp-4.0.1.5/config.make
+
+# Make the proto using the bootstrap, then make the final compiler using the proto
+# We call MAKE sequentially because we don't want build-final to explicitly depend on build-proto,
+# as that causes a complete recompilation of both proto and final everytime you touch the
+# compiler sources.
+all:
+ $(MAKE) build-proto
+ $(MAKE) build
+
+# We need the bootstrap's FSharp.Core to run the proto
+build-proto: $(bootstrap)/FSharp.Core.dll $(bootstrap)/FSharp.Core.sigdata $(bootstrap)/FSharp.Core.optdata
+ @-mkdir -p $(protodir)
+ #ls -R $(monolibdir)/..
+ cp -p $(bootstrap)/FSharp.Core.dll $(protodir)FSharp.Core.dll
+ cp -p $(bootstrap)/FSharp.Core.sigdata $(protodir)FSharp.Core.sigdata
+ cp -p $(bootstrap)/FSharp.Core.optdata $(protodir)FSharp.Core.optdata
+ $(MAKE) -C FSharp.Build-proto Configuration=proto $@
+ $(MAKE) -C FSharp.Compiler-proto Configuration=proto $@
+ $(MAKE) -C Fsc-proto Configuration=proto $@
+
+# The main targets
+#
+# - Only build a net20 version of FSharp.Core if net20 mscorlib exists
+# Modern versions of mono no longer include net20 or net35 assemblies
+#
+build clean install:
+ $(MAKE) -C FSharp.Core TargetFramework=net40 $@
+ $(MAKE) -C FSharp.Build $@
+ $(MAKE) -C FSharp.Compiler $@
+ $(MAKE) -C Fsc $@
+ $(MAKE) -C FSharp.Compiler.Interactive.Settings $@
+ $(MAKE) -C FSharp.Compiler.Server.Shared $@
+ $(MAKE) -C fsi $@
+ $(MAKE) -C fsiAnyCpu $@
+ $(MAKE) -C policy.2.0.FSharp.Core $@
+ $(MAKE) -C policy.2.3.FSharp.Core $@
+ $(MAKE) -C policy.3.3.FSharp.Core $@
+ $(MAKE) -C policy.3.7.FSharp.Core $@
+ $(MAKE) -C policy.3.47.FSharp.Core $@
+ $(MAKE) -C policy.3.78.FSharp.Core $@
+ $(MAKE) -C policy.3.259.FSharp.Core $@
+ $(MAKE) -C policy.4.0.FSharp.Core $@
+ $(MAKE) -C policy.4.3.FSharp.Core $@
+ if test -e $MONOGACDIR20/mscorlib.dll; then $(MAKE) -C FSharp.Core TargetFramework=net20 $@;fi
+ $(MAKE) only-monotouch only-monodroid only-xamarinmac
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.0 TargetFramework=net40 $@
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.1 TargetFramework=net40 $@
+ if test -e $MONOGACDIR20/mscorlib.dll; then $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.0 TargetFramework=net20 $@;fi
+ifeq ("$(pclenabled47)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=portable47 $@
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.0 TargetFramework=portable47 $@
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.1 TargetFramework=portable47 $@
+endif
+ifeq ("$(pclenabled7)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=portable7 $@
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.1 TargetFramework=portable7 $@
+endif
+ifeq ("$(pclenabled78)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=portable78 $@
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.1 TargetFramework=portable78 $@
+endif
+ifeq ("$(pclenabled259)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=portable259 $@
+ $(MAKE) -C FSharp.Core FSharpCoreBackVersion=3.1 TargetFramework=portable259 $@
+endif
+
+all-monotouch-monodroid-xamarinmac:
+ $(MAKE) build-proto
+ $(MAKE) only-monotouch only-monodroid only-xamarinmac only-xamarinwatchos only-xamarintvos
+
+all-monotouch-xamarinmac:
+ $(MAKE) build-proto
+ $(MAKE) only-monotouch only-xamarinmac only-xamarinwatchos only-xamarintvos
+
+all-monotouch-monodroid:
+ $(MAKE) build-proto
+ $(MAKE) only-monotouch only-monodroid only-xamarinwatchos only-xamarintvos
+
+all-monotouch:
+ $(MAKE) build-proto
+ $(MAKE) only-monotouch only-xamarinwatchos only-xamarintvos
+
+only-monotouch:
+ifeq ("$(monotouchenabled)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=monotouch build
+endif
+
+only-xamarinwatchos:
+ifeq ("$(monotouchenabled)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=xamarinwatchos build
+endif
+
+only-xamarintvos:
+ifeq ("$(monotouchenabled)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=xamarintvos build
+endif
+
+all-monodroid:
+ $(MAKE) build-proto
+ $(MAKE) only-monodroid
+
+only-monodroid:
+ifeq ("$(monodroidenabled)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=monodroid build
+endif
+
+all-xamarinmac:
+ $(MAKE) build-proto
+ $(MAKE) only-xamarinmac
+
+only-xamarinmac: only-xamarinmacmobile only-xamarinmacfull
+
+only-xamarinmacmobile:
+ifeq ("$(xamarinmacenabled)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=xamarinmacmobile build
+endif
+
+only-xamarinmacfull:
+ifeq ("$(xamarinmacenabled)", "yes")
+ $(MAKE) -C FSharp.Core TargetFramework=xamarinmacfull build
+endif
diff --git a/PKGBUILD b/PKGBUILD
index cd5b1a16625a..c113b5a0d626 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
# Maintainer: Mort Yao <soi@mort.ninja>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Brenton Horne <brentonhorne77 at gmail dot com>
pkgname=fsharp
-pkgver=4.0.1.1
-pkgrel=2
+pkgver=4.0.1.5
+pkgrel=1
pkgdesc="The Open Edition of the F# compiler, core library and tools"
arch=('any')
url="http://fsharp.org/"
license=('Apache')
depends=('mono>=4.0.3.20')
-source=($pkgname-$pkgver.tar.gz::https://github.com/fsharp/$pkgname/archive/$pkgver.tar.gz)
-md5sums=('2dd3cc2cf130615bc79ceb1b93141e2b')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/fsharp/$pkgname/archive/$pkgver.tar.gz"
+"Makefile")
+md5sums=('5974b6df0aa6df01f153afadcbdc6061'
+ '72399b0b526807ff847d7d090344a36c')
build() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
./autogen.sh --prefix=/usr
+ cp $srcdir/Makefile $srcdir/fsharp-$pkgver/src/fsharp
+ sed -i -e "s|<SRCDIR>|$srcdir|g" $srcdir/fsharp-$pkgver/src/fsharp/Makefile
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ find "${pkgdir}" \
+ -name "*.xml" -exec sed -i -e "s|$srcdir||g" '{}' \;
}