summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrett Gilio2018-09-05 20:12:59 -0500
committerBrett Gilio2018-09-05 20:12:59 -0500
commitf936e20238bd5ca4dbaa8a590bd683b87fb9be44 (patch)
tree5b1e6a2014f2cebb632fb671a111c787c0fd5274
parent8b5dcacf1bfd3102ac2dae5c0dd7641b435384de (diff)
downloadaur-f936e20238bd5ca4dbaa8a590bd683b87fb9be44.tar.gz
Fix symlink install
-rw-r--r--.PKGBUILD.kate-swpbin0 -> 77 bytes
-rwxr-xr-xPKGBUILD4
-rw-r--r--autogen.sh4
3 files changed, 6 insertions, 2 deletions
diff --git a/.PKGBUILD.kate-swp b/.PKGBUILD.kate-swp
new file mode 100644
index 000000000000..9eaa11d84f2e
--- /dev/null
+++ b/.PKGBUILD.kate-swp
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
index 3641d5603960..8b467793f0bc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ url="http://fsharp.org/"
license=('MIT')
depends=('mono' 'msbuild-stable')
makedepends=(git)
-_commit=32505e2035ebf3ae3267c1eb2afad8800a7106f8 # tags/4.1.35
+_commit=32505e2035ebf3ae3267c1eb2afad8800a7106f8 # tags/4.5_pre
source=("git+https://github.com/fsharp/fsharp/#commit=$_commit")
sha256sums=('SKIP')
@@ -23,7 +23,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
- #./autogen.sh --prefix=/usr
+ ../autogen.sh --prefix=/usr
make
}
diff --git a/autogen.sh b/autogen.sh
new file mode 100644
index 000000000000..baa225f86658
--- /dev/null
+++ b/autogen.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/env sh
+
+which autoreconf > /dev/null || (echo "Please install autoconf" && exit 1)
+autoreconf && ./configure $@