summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-10-24 07:26:30 +0000
committerAntonio Rojas2017-10-24 07:26:30 +0000
commitfab6a8323d4fc1baf8360ddb6a03a9df0cb3622f (patch)
tree6cba0a23b7ca8355e0d66950c3a324bd9e46a7a5
parent22d61878dcaf46819c35e6bf51b93409e016bc41 (diff)
downloadaur-fab6a8323d4fc1baf8360ddb6a03a9df0cb3622f.tar.gz
Dropped from repos
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD22
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7a277eada07..f1a8b4843ea5 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
-# Generated by mksrcinfo v8
-# Mon Nov 14 13:32:47 UTC 2016
pkgbase = fsharp
pkgdesc = The Open Edition of the F# compiler, core library and tools
- pkgver = 4.0.1.20
+ pkgver = 4.1.18
pkgrel = 1
url = http://fsharp.org/
arch = any
license = Apache
- depends = mono>=4.0.3.20
- source = fsharp-4.0.1.20.tar.gz::https://github.com/fsharp/fsharp/archive/4.0.1.20.tar.gz
- md5sums = b4b721e369b27822eb0e1275694c7152
+ makedepends = git
+ depends = mono
+ source = git+https://github.com/fsharp/fsharp/#commit=3245fd24efcc7a54d4314a2897257f68cd194244
+ sha256sums = SKIP
pkgname = fsharp
diff --git a/PKGBUILD b/PKGBUILD
index 60ae851db8b6..47eee0b9e7f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
-# Maintainer: Mort Yao <soi@mort.ninja>
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Mort Yao <soi@mort.ninja>
# Contributor: Balló György <ballogyor+arch at gmail dot com>
pkgname=fsharp
-pkgver=4.0.1.20
+pkgver=4.1.18
pkgrel=1
pkgdesc="The Open Edition of the F# compiler, core library and tools"
arch=('any')
url="http://fsharp.org/"
license=('Apache')
-depends=('mono>=4.0.3.20')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/fsharp/$pkgname/archive/$pkgver.tar.gz")
-md5sums=('b4b721e369b27822eb0e1275694c7152')
+depends=('mono')
+makedepends=(git)
+_commit=3245fd24efcc7a54d4314a2897257f68cd194244 # tags/4.1.18
+source=("git+https://github.com/fsharp/fsharp/#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
./autogen.sh --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir" install
}