summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormdarocha2020-07-19 14:37:02 +0200
committermdarocha2020-07-19 14:37:02 +0200
commit05fa7cd8612cf264c20214b931516f4528ac45ef (patch)
tree5dba3865898749a7947b4063a3d4b3dd104d8ef1
downloadaur-05fa7cd8612cf264c20214b931516f4528ac45ef.tar.gz
Hello world! Create pkgbuild for v0.1.27
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..804f88526ce9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fsharp-language-server
+ pkgdesc = Language server for F#, utilizing the Language Server Protocol
+ pkgver = 0.1.27
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/fsprojects/fsharp-language-server
+ arch = x86_64
+ license = MIT
+ makedepends = dotnet-sdk>=3.1.3
+ depends = dotnet-host>=3.1.3
+ options = !strip
+ source = https://github.com/fsprojects/fsharp-language-server/archive/v0.1.27.tar.gz
+ md5sums = e19288c77c6511ad21fa3b8f66b9c71e
+
+pkgname = fsharp-language-server
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b39f3b2a183f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c9d56988459
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Marek Darocha <aur@mdarocha.pl>
+pkgname=fsharp-language-server
+pkgver=0.1.27
+pkgrel=1
+epoch=0
+pkgdesc="Language server for F#, utilizing the Language Server Protocol"
+arch=('x86_64')
+url="https://github.com/fsprojects/fsharp-language-server"
+license=('MIT')
+depends=('dotnet-host>=3.1.3')
+makedepends=('dotnet-sdk>=3.1.3')
+source=("https://github.com/fsprojects/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('e19288c77c6511ad21fa3b8f66b9c71e')
+options=(!strip)
+
+build() {
+ cd "${srcdir}"/"${pkgname}-${pkgver}"/
+ dotnet publish src/FSharpLanguageServer/FSharpLanguageServer.fsproj -c Release --self-contained false -p:PublishSingleFile=true -p:RuntimeIdentifier=linux-x64 -o ./out/
+}
+
+package() {
+ umask 022
+ install -Dm755 "${srcdir}"/"${pkgname}-${pkgver}"/out/FSharpLanguageServer "${pkgdir}"/usr/bin/"${pkgname}"
+}