summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2019-04-10 12:44:39 +0200
committerTobias Bachmann2019-04-10 12:44:39 +0200
commitfe0bcfd65800ff66e07200c7d5a4e75d4134e5cb (patch)
treee37effa72cf9fbf2c306ae01405b09e8590a08ab
parentb3c3b64fef6273db73dd82c0dfe32d3f91a561dd (diff)
downloadaur-fe0bcfd65800ff66e07200c7d5a4e75d4134e5cb.tar.gz
Initial upload
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07817a1685f3..6262f6fb41e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = fsl-palm
- pkgdesc = PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis of Linear Models
+ pkgdesc = PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis for the Linear Model
pkgver = alpha115
- pkgrel = 1
+ pkgrel = 2
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/PALM
arch = any
license = GPL
- depends = octave
depends = fsl
+ depends = octave
+ depends = octave-image
source = https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/palm-alpha115.tar.gz
source = 001-adjust_path_for_systemwide_install.patch
sha256sums = e3f31cb94a98003ce1384e5d5c9f2901a25023a2132f36317efdf7f208b84ba4
diff --git a/PKGBUILD b/PKGBUILD
index 1bb4043cc121..457ec957bb39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsl-palm
pkgver=alpha115
-pkgrel=1
-pkgdesc="PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis of Linear Models"
+pkgrel=2
+pkgdesc="PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis for the Linear Model"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/PALM"
license=('GPL')
-depends=('octave' 'fsl')
+depends=('fsl' 'octave' 'octave-image')
source=("https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/${pkgname##fsl-}-${pkgver}.tar.gz"
"001-adjust_path_for_systemwide_install.patch")
sha256sums=('e3f31cb94a98003ce1384e5d5c9f2901a25023a2132f36317efdf7f208b84ba4'
@@ -17,6 +17,16 @@ prepare() {
patch -Np1 -i "${srcdir}"/001-adjust_path_for_systemwide_install.patch
}
+build() {
+ # We need to rebuild .mex files due to newer Octave version on Arch
+ cd "${srcdir}"
+ for sourcefile in $(find . -type f -name '*.c'); do
+ outfile=${sourcefile//.c/.mex}
+ rm "${outfile}" # Unneccessary, just for clarity purposes
+ /usr/bin/mkoctfile -v --mex "${sourcefile}" -o "${outfile}"
+ done
+}
+
package() {
mkdir -p "${pkgdir}"/usr/lib
mkdir "${pkgdir}"/usr/bin