summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2019-04-10 13:02:30 +0200
committerTobias Bachmann2019-04-10 13:02:30 +0200
commitfe7824f2fd61e167e5a207f441c26a3af0f6a8da (patch)
tree1b3bacd69ac7e443d9bbc2b6a95a3e96fc0cc9ea
parentfe0bcfd65800ff66e07200c7d5a4e75d4134e5cb (diff)
downloadaur-fe7824f2fd61e167e5a207f441c26a3af0f6a8da.tar.gz
Initial upload
-rw-r--r--.SRCINFO4
-rw-r--r--001-adjust_path_for_systemwide_install.patch29
-rw-r--r--PKGBUILD4
3 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6262f6fb41e5..26ffd47d8b1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fsl-palm
pkgdesc = PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis for the Linear Model
pkgver = alpha115
- pkgrel = 2
+ pkgrel = 3
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/PALM
arch = any
license = GPL
@@ -11,7 +11,7 @@ pkgbase = fsl-palm
source = https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/palm-alpha115.tar.gz
source = 001-adjust_path_for_systemwide_install.patch
sha256sums = e3f31cb94a98003ce1384e5d5c9f2901a25023a2132f36317efdf7f208b84ba4
- sha256sums = f68225784834769b6a63f7aab741acdc63f1e966041527064f3dddba4c23909f
+ sha256sums = 5722799901bc23ca1f391418d6e9d20e92ecce89612cd6e0185cffd51d06bff2
pkgname = fsl-palm
diff --git a/001-adjust_path_for_systemwide_install.patch b/001-adjust_path_for_systemwide_install.patch
index a07b5aa188cf..40421e318ac9 100644
--- a/001-adjust_path_for_systemwide_install.patch
+++ b/001-adjust_path_for_systemwide_install.patch
@@ -1,11 +1,28 @@
--- a/palm 2019-04-10 09:38:38.217727011 +0200
-+++ b/palm 2019-04-10 09:38:51.558320325 +0200
-@@ -54,7 +54,7 @@
++++ b/palm 2019-04-10 13:00:12.599546441 +0200
+@@ -53,24 +53,7 @@
+ # Normally there is no need to edit below this line:
# Locate PALM
- cmdfull=${BASH_SOURCE[0]}
+-cmdfull=${BASH_SOURCE[0]}
-PALMDIR=$(dirname ${cmdfull})
+-rlink=$(readlink ${cmdfull})
+-cnt=1
+-while [[ ${rlink} != "" ]] && [[ ${cnt} -lt 100 ]]; do
+- dirnam=$(dirname ${rlink})
+- if [[ ${dirnam:0} == "/" ]] ; then
+- PALMDIR=${dirnam}
+- else
+- PALMDIR="${PALMDIR}/${dirnam}"
+- fi
+- rlink=$(readlink ${rlink})
+- cnt=$(expr ${cnt} + 1)
+-done
+-if [[ ${cnt} -eq 100 ]] ; then
+- echo "Error: Too many levels of symbolic links."
+- exit 1
+-fi
+PALMDIR=/usr/lib/palm
- rlink=$(readlink ${cmdfull})
- cnt=1
- while [[ ${rlink} != "" ]] && [[ ${cnt} -lt 100 ]]; do
+
+ # Command to run inside either Octave or Matlab. It varies slightly
+ # depending whether it's a cluster environment or not.
diff --git a/PKGBUILD b/PKGBUILD
index 457ec957bb39..13eea84025fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsl-palm
pkgver=alpha115
-pkgrel=2
+pkgrel=3
pkgdesc="PALM is a set of GNU Octave/MATLAB scripts to perform Permutation Analysis for the Linear Model"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/PALM"
@@ -10,7 +10,7 @@ depends=('fsl' 'octave' 'octave-image')
source=("https://s3-us-west-2.amazonaws.com/andersonwinkler/palm/${pkgname##fsl-}-${pkgver}.tar.gz"
"001-adjust_path_for_systemwide_install.patch")
sha256sums=('e3f31cb94a98003ce1384e5d5c9f2901a25023a2132f36317efdf7f208b84ba4'
- 'f68225784834769b6a63f7aab741acdc63f1e966041527064f3dddba4c23909f')
+ '5722799901bc23ca1f391418d6e9d20e92ecce89612cd6e0185cffd51d06bff2')
prepare() {
cd "${srcdir}"/${pkgname##fsl-}-${pkgver}