summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2018-09-15 20:47:21 +0200
committerTobias Bachmann2018-09-15 20:47:21 +0200
commit73799313e7b4e2685619de4e08b841f794323d08 (patch)
tree051deb948fa83b6f1570eca9da9b21c5b1249d49
parentc2c9282c67598fee8f1896050ee5daa8d66d1a03 (diff)
downloadaur-73799313e7b4e2685619de4e08b841f794323d08.tar.gz
Version bump
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36eefe3fec5f..85d0f3009f3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fsleyes
pkgdesc = FSLeyes is the FSL image viewer
- pkgver = 0.24.2
- pkgrel = 2
+ pkgver = 0.25.0
+ pkgrel = 1
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes
arch = any
license = Apache
@@ -18,19 +18,18 @@ pkgbase = fsleyes
depends = python-scipy
depends = python-opengl-accelerate
depends = python-wxpython>=4.0.1-2
+ depends = python-pypubsub
depends = fsl
depends = fsleyes-widgets>=0.6.2
depends = fsleyes-props>=1.6.2
- depends = python-wxnatpy>=0.3.1
+ depends = python-wxnatpy>=0.3.1-2
depends = python-indexed-gzip>=0.7.0
- source = fsleyes-0.24.2.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/repository/archive.tar.gz?ref=0.24.2
+ source = fsleyes-0.25.0.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/repository/archive.tar.gz?ref=0.25.0
source = fsleyes.png::https://git.fmrib.ox.ac.uk/uploads/-/system/group/avatar/85/icon_512x512.png
source = fsleyes.desktop
- source = 0001-remove_appnope.patch
- sha256sums = 05b310e2f36aa06326d4bf4c508b156ad49c928976d0a240fedd5b197435f4a0
+ sha256sums = 3067f4f070c39c4ee198759270a143da713f53930e336ef910b85c0b5769a358
sha256sums = c7211ee624483a272f280b3aa772046ec9226d838f9c3023450888abddf9d71a
sha256sums = 6e91e88eb74602f8da7cda6575245dbaaf4577022bffe15c0efedb33106139fb
- sha256sums = 6b6094b9fe888cfb9b86010b457bd8ad97b4c1242bc7d64557fe83d566f56fc6
pkgname = fsleyes
diff --git a/PKGBUILD b/PKGBUILD
index fa7f90c23c0c..ccb0f7063aee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,28 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes
-pkgver=0.24.2
-pkgrel=2
+pkgver=0.25.0
+pkgrel=1
pkgdesc="FSLeyes is the FSL image viewer"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
-depends=('python' 'python-sphinx' 'python-six' 'python-numpy' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-pillow' 'python-opengl' 'python-pyparsing' 'python-scipy' 'python-opengl-accelerate' 'python-wxpython>=4.0.1-2' 'fsl' 'fsleyes-widgets>=0.6.2' 'fsleyes-props>=1.6.2' 'python-wxnatpy>=0.3.1' 'python-indexed-gzip>=0.7.0')
+depends=('python' 'python-sphinx' 'python-six' 'python-numpy' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-pillow' 'python-opengl' 'python-pyparsing' 'python-scipy' 'python-opengl-accelerate' 'python-wxpython>=4.0.1-2' 'python-pypubsub' 'fsl' 'fsleyes-widgets>=0.6.2' 'fsleyes-props>=1.6.2' 'python-wxnatpy>=0.3.1-2' 'python-indexed-gzip>=0.7.0')
makedepends=()
provides=()
conflicts=()
replaces=()
source=("${pkgname}-${pkgver}.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/repository/archive.tar.gz?ref=${pkgver}"
"${pkgname}.png::https://git.fmrib.ox.ac.uk/uploads/-/system/group/avatar/85/icon_512x512.png"
- "${pkgname}.desktop"
- "0001-remove_appnope.patch")
-sha256sums=('05b310e2f36aa06326d4bf4c508b156ad49c928976d0a240fedd5b197435f4a0'
+ "${pkgname}.desktop")
+sha256sums=('3067f4f070c39c4ee198759270a143da713f53930e336ef910b85c0b5769a358'
'c7211ee624483a272f280b3aa772046ec9226d838f9c3023450888abddf9d71a'
- '6e91e88eb74602f8da7cda6575245dbaaf4577022bffe15c0efedb33106139fb'
- '6b6094b9fe888cfb9b86010b457bd8ad97b4c1242bc7d64557fe83d566f56fc6')
+ '6e91e88eb74602f8da7cda6575245dbaaf4577022bffe15c0efedb33106139fb')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}-"*
# "Patching" for Pillow>=5.0 support
sed -i 's/Pillow>=3\.2\.0,<5\.0/Pillow>=3\.2\.0/g' requirements.txt
- # Removing Mac OS-specific appnope requirement
- sed -i 's/appnope==0\.1\.\*//g' requirements.txt
- patch -p0 <"${srcdir}"/0001-remove_appnope.patch
}
package() {