summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2018-10-30 09:07:55 +0100
committerTobias Bachmann2018-10-30 09:07:55 +0100
commitbec88082fbffe804141d4147608e36ac58e76e3f (patch)
treed994646dfb33ba35c5da0fedc509dea4f7698fd5
parent0f2a63b6eb709a285d8415a2af4413971cc0c53d (diff)
downloadaur-bec88082fbffe804141d4147608e36ac58e76e3f.tar.gz
Patching for matplotlib>3.0.0 support
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecdb80e159ac..851e0a9bb318 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = fsleyes
pkgdesc = FSLeyes is the FSL image viewer
pkgver = 0.26.4
- pkgrel = 1
+ pkgrel = 2
url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes
arch = any
license = Apache
@@ -21,8 +21,8 @@ pkgbase = fsleyes
depends = python-wxpython>=4.0.1-2
depends = fsl
depends = fslpy>=1.12.0
- depends = fsleyes-widgets>=0.7.0
- depends = fsleyes-props>=1.6.4
+ depends = fsleyes-widgets>=0.7.0-2
+ depends = fsleyes-props>=1.6.4-2
depends = python-wxnatpy>=0.3.1-2
depends = python-indexed-gzip>=0.8.7
source = fsleyes-0.26.4.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/fsleyes/repository/archive.tar.gz?ref=0.26.4
diff --git a/PKGBUILD b/PKGBUILD
index cc989e71ce0e..fd07f21319ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=fsleyes
pkgver=0.26.4
-pkgrel=1
+pkgrel=2
pkgdesc="FSLeyes is the FSL image viewer"
arch=('any')
url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
license=('Apache')
groups=()
-depends=('python' 'python-setuptools' 'python-sphinx' 'python-six' 'python-numpy' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-pillow' 'python-opengl' 'python-pyparsing' 'python-scipy' 'python-opengl-accelerate' 'python-wxpython>=4.0.1-2' 'fsl' 'fslpy>=1.12.0' 'fsleyes-widgets>=0.7.0' 'fsleyes-props>=1.6.4' 'python-wxnatpy>=0.3.1-2' 'python-indexed-gzip>=0.8.7')
+depends=('python' 'python-setuptools' 'python-sphinx' 'python-six' 'python-numpy' 'python-matplotlib' 'python-nibabel' 'python-jinja' 'python-pillow' 'python-opengl' 'python-pyparsing' 'python-scipy' 'python-opengl-accelerate' 'python-wxpython>=4.0.1-2' 'fsl' 'fslpy>=1.12.0' 'fsleyes-widgets>=0.7.0-2' 'fsleyes-props>=1.6.4-2' 'python-wxnatpy>=0.3.1-2' 'python-indexed-gzip>=0.8.7')
makedepends=()
provides=()
conflicts=()
@@ -23,6 +23,8 @@ prepare() {
cd "${srcdir}/${pkgname}-${pkgver}-"*
# "Patching" for Pillow>=5.0 support
sed -i 's/Pillow>=3\.2\.0,<5\.0/Pillow>=3\.2\.0/g' requirements.txt
+ # "Patching" for matplotlib>3.0.0 support
+ sed -i 's/matplotlib>=1\.5\.1,<3\.0\.0/matplotlib>=1.5.1/g' requirements.txt
}
package() {