summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2017-10-11 13:10:27 +0200
committerTobias Bachmann2017-10-11 13:10:27 +0200
commit5856c410e1915d28cacf0e5760384b5dcef13db0 (patch)
treea681fee051e70de42efdc1d1f31ac4f946d6be2a
downloadaur-5856c410e1915d28cacf0e5760384b5dcef13db0.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8ca1181be2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fsleyes-widgets
+ pkgdesc = FSLeyes is the FSL image viewer, widgets is one of its dependent projects
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes
+ arch = any
+ license = Apache
+ makedepends = python-six
+ makedepends = python-numpy
+ makedepends = python-matplotlib
+ makedepends = wxpython-phoenix
+ depends = python
+ source = fsleyes-widgets-0.0.6.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/repository/archive.tar.gz?ref=0.0.6
+ sha256sums = a040846a4f968a82f09578c05877ecc752fe10a7fed4af94515170fae1f13082
+
+pkgname = fsleyes-widgets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b7d42b71b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgname=fsleyes-widgets
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="FSLeyes is the FSL image viewer, widgets is one of its dependent projects"
+arch=('any')
+url="https://fsl.fmrib.ox.ac.uk/fsl/fslwiki/FSLeyes"
+license=('Apache')
+groups=()
+depends=('python')
+makedepends=('python-six' 'python-numpy' 'python-matplotlib' 'wxpython-phoenix')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+source=($pkgname-$pkgver.tar.gz::https://git.fmrib.ox.ac.uk/fsl/fsleyes/widgets/repository/archive.tar.gz?ref=$pkgver)
+sha256sums=('a040846a4f968a82f09578c05877ecc752fe10a7fed4af94515170fae1f13082')
+
+package() {
+ cd "$srcdir/${pkgname#fsleyes-}-$pkgver-"*
+ python setup.py install --root="$pkgdir/" --optimize=1
+}