summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:09:12 +0100
committerSteven Honeyman2015-06-09 19:09:12 +0100
commita9d8453476d253151e7b799f631f7adcb19ac1cd (patch)
tree785f96dcce385f386fef1152deb246e0c1657fec
downloadaur-a9d8453476d253151e7b799f631f7adcb19ac1cd.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD59
-rw-r--r--fslint-2.44_fix-multiselect-regression_r291.patch31
-rw-r--r--fslint-2.44_gtk-init-graceful_r292.patch24
5 files changed, 147 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a64f2ee48737
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = fslint
+ pkgdesc = A utility to find and clean various forms of lint on a filesystem
+ pkgver = 2.44
+ pkgrel = 2
+ url = http://www.pixelbeat.org/fslint/
+ arch = any
+ license = GPL
+ depends = pygtk
+ depends = python2
+ source = http://www.pixelbeat.org/fslint/fslint-2.44.tar.gz
+ source = fslint-2.44_fix-multiselect-regression_r291.patch
+ source = fslint-2.44_gtk-init-graceful_r292.patch
+
+pkgname = fslint
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..902717e22ed4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fslint
+ pkgdesc = A utility to find and clean various forms of lint on a filesystem
+ pkgver = 2.44
+ pkgrel = 2
+ url = http://www.pixelbeat.org/fslint/
+ arch = any
+ license = GPL
+ depends = pygtk
+ depends = python2
+ source = http://www.pixelbeat.org/fslint/fslint-2.44.tar.gz
+ source = fslint-2.44_fix-multiselect-regression_r291.patch
+ source = fslint-2.44_gtk-init-graceful_r292.patch
+ sha256sums = 8491a9cd76725e652ac8fe07288ba1f896d9331e30593c0ff3ab9e82e863f0ae
+ sha256sums = f8786f1c564678e01cd2b52674a48e61858661f5337f5332a7635de5f082c239
+ sha256sums = 4a87d8bbe6699f0932af2c06d38ba6547bd8905e4db51404b3db4c3e3d36c9a9
+
+pkgname = fslint
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77d938b05077
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+# Patches taken from upstream svn to fix specific problems that
+# Arch Linux users were having (see AUR comments) - 2014-06-09
+
+pkgname=fslint
+pkgver=2.44
+pkgrel=2
+pkgdesc="A utility to find and clean various forms of lint on a filesystem"
+arch=('any')
+url="http://www.pixelbeat.org/fslint/"
+license=('GPL')
+depends=('pygtk' 'python2')
+source=(http://www.pixelbeat.org/$pkgname/$pkgname-$pkgver.tar.gz
+ fslint-2.44_fix-multiselect-regression_r291.patch
+ fslint-2.44_gtk-init-graceful_r292.patch)
+sha256sums=('8491a9cd76725e652ac8fe07288ba1f896d9331e30593c0ff3ab9e82e863f0ae'
+ 'f8786f1c564678e01cd2b52674a48e61858661f5337f5332a7635de5f082c239'
+ '4a87d8bbe6699f0932af2c06d38ba6547bd8905e4db51404b3db4c3e3d36c9a9')
+
+prepare() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ sed -i -e s_^liblocation=.*_liblocation=\'/usr/share/fslint\'_ fslint-gui
+
+ # fixes a regression with multiple select in duplicate file finder
+ patch -p2 -i ../fslint-2.44_fix-multiselect-regression_r291.patch
+
+ # handle gtk init problem gracefully
+ patch -p2 -i ../fslint-2.44_gtk-init-graceful_r292.patch
+
+ sed -i 's/env python/&2/' fslint-gui \
+ fslint/fstool/dupwaste \
+ fslint/supprt/rmlint/fixdup \
+ fslint/supprt/rmlint/merge_hardlinks
+ sed -i 's/bin.python/&2/' fslint/supprt/md5sum_approx
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ install -d "${pkgdir}"/usr/share/{man/man1,doc/$pkgname,pixmaps}
+ install -d "${pkgdir}"/usr/share/$pkgname/fslint/{fstool,supprt/rmlint}
+
+ install -D -m755 -t "${pkgdir}"/usr/share/$pkgname/$pkgname $pkgname/find* $pkgname/zipdir $pkgname/fslint
+ install -D -m755 -t "${pkgdir}"/usr/share/$pkgname/$pkgname/fstool $pkgname/fstool/*
+ install -D -m755 -t "${pkgdir}"/usr/share/$pkgname/$pkgname/supprt $pkgname/supprt/get* $pkgname/supprt/fslver $pkgname/supprt/md5sum_approx
+ install -D -m755 -t "${pkgdir}"/usr/share/$pkgname/$pkgname/supprt/rmlint fslint/supprt/rmlint/*
+ install -D -m755 $pkgname-gui "${pkgdir}"/usr/bin/$pkgname-gui
+ install -D -m644 $pkgname.glade "${pkgdir}"/usr/share/$pkgname/$pkgname.glade
+ install -D -m644 $pkgname.desktop "${pkgdir}"/usr/share/applications/$pkgname.desktop
+ install -D -m644 fslint_icon.png "${pkgdir}"/usr/share/$pkgname/fslint_icon.png
+ ln -s /usr/share/$pkgname/fslint_icon.png "${pkgdir}"/usr/share/pixmaps/fslint_icon.png
+
+ cp -r "${srcdir}"/$pkgname-$pkgver/man/* "${pkgdir}"/usr/share/man/man1
+ cp -r "${srcdir}"/$pkgname-$pkgver/doc/* "${pkgdir}"/usr/share/doc/$pkgname
+
+ make -C po DESTDIR="${pkgdir}" install
+}
diff --git a/fslint-2.44_fix-multiselect-regression_r291.patch b/fslint-2.44_fix-multiselect-regression_r291.patch
new file mode 100644
index 000000000000..d8cd95c1ebe1
--- /dev/null
+++ b/fslint-2.44_fix-multiselect-regression_r291.patch
@@ -0,0 +1,31 @@
+--- a/fslint-2.44/fslint-gui
++++ b/fslint-2.44/fslint-gui
+@@ -782,8 +782,8 @@
+ if row == clist.rows-1 and not get_selectable(row-1, row_data):
+ clist.remove(row)
+ row_data.pop(row)
+- elif not (get_selectable(row-1, row_data) or
+- get_selectable(row+1, row_data)):
++ elif not ((row!=0 and get_selectable(row-1, row_data)) or
++ (row!=clist.rows-1 and get_selectable(row+1, row_data))):
+ clist.remove(row)
+ row_data.pop(row)
+
+@@ -1599,7 +1599,7 @@
+ if row!=0 or not get_selectable(row, row_data):
+ row += 1 #for all except first row in clist_sn
+ unselect_row = -1 # avoid rh bug 726252 (mtimes for group = -1?)
+- while get_selectable(row, row_data) and row < clist.rows:
++ while row < clist.rows and get_selectable(row, row_data):
+ mtime = clist.get_row_data(row)
+ if comp(mtime,unselect_mtime):
+ unselect_mtime = mtime
+@@ -1638,7 +1638,7 @@
+ def group_all_selected(clist, row):
+ if row!=0 or not get_selectable(row, row_data): #for first sn row
+ row += 1
+- while get_selectable(row, row_data) and row < clist.rows:
++ while row < clist.rows and get_selectable(row, row_data):
+ if not row in selected:
+ return False
+ row += 1
diff --git a/fslint-2.44_gtk-init-graceful_r292.patch b/fslint-2.44_gtk-init-graceful_r292.patch
new file mode 100644
index 000000000000..caecdea5d8b6
--- /dev/null
+++ b/fslint-2.44_gtk-init-graceful_r292.patch
@@ -0,0 +1,24 @@
+--- a/fslint-2.44/fslint-gui
++++ b/fslint-2.44/fslint-gui
+@@ -22,12 +22,19 @@
+ which is available at www.gnu.org
+ """
+
++import types, os, sys, pipes, time, stat, tempfile, errno
++
+ import gettext
+ import locale
+-import gtk
+-import gtk.glade
+
+-import types, os, sys, pipes, time, stat, tempfile, errno
++try:
++ import gtk
++except RuntimeError:
++ etype, emsg, etb = sys.exc_info()
++ sys.stderr.write(str(emsg)+'\n')
++ sys.exit(1)
++
++import gtk.glade
+
+ time_commands=False #print sub commands timing on status line