summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-24 18:20:44 +0800
committerzxp198210052024-01-24 18:20:44 +0800
commit09d24112b6d2d4040807f9f6cde89f7c2f7dae1b (patch)
tree7a54306abdac2ee50e7996ef43be00e341a87205
parent806088ca5c642980388ca737c1991632626db376 (diff)
downloadaur-09d24112b6d2d4040807f9f6cde89f7c2f7dae1b.tar.gz
update to 1.9.2-prod.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--fsolauncher.sh9
3 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f62c0feed44e..de34f068c4e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fsolauncher
pkgdesc = Official FreeSO Launcher made with Electron
- pkgver = 1.9.2_prod.2
+ pkgver = 1.9.2_prod.3
pkgrel = 1
url = https://beta.freeso.org/
arch = x86_64
@@ -11,9 +11,9 @@ pkgbase = fsolauncher
makedepends = git
depends = electron22
conflicts = fsolauncher
- source = fsolauncher-1.9.2_prod.2::git+https://github.com/ItsSim/fsolauncher.git#tag=1.9.2-prod.2
+ source = fsolauncher.git::git+https://github.com/ItsSim/fsolauncher.git#tag=1.9.2-prod.3
source = fsolauncher.sh
sha256sums = SKIP
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = fsolauncher
diff --git a/PKGBUILD b/PKGBUILD
index 1fc0c3da1760..e1d5fcd68799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=fsolauncher
-pkgver=1.9.2_prod.2
+_pkgname="FreeSO Launcher"
+pkgver=1.9.2_prod.3
_electronversion=22
_nodeversion=16
pkgrel=1
@@ -20,11 +21,11 @@ makedepends=(
'git'
)
source=(
- "${pkgname}-${pkgver}::git+${_ghurl}.git#tag=${pkgver//_/-}"
+ "${pkgname}.git::git+${_ghurl}.git#tag=${pkgver//_/-}"
"${pkgname%-bin}.sh"
)
sha256sums=('SKIP'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
@@ -37,8 +38,8 @@ build() {
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname}.sh"
_ensure_local_nvm
- gendesk -f -n -q --categories "Game" --name "${pkgname}" --exec "${pkgname}"
- cd "${srcdir}/${pkgname}-${pkgver}/src"
+ gendesk -f -n -q --categories "Game" --name "${_pkgname}" --exec "${pkgname} %U"
+ cd "${srcdir}/${pkgname}.git/src"
export npm_config_build_from_source=true
export npm_config_cache="${srcdir}/.npm_cache"
export ELECTRON_SKIP_BINARY_DOWNLOAD=1
@@ -49,7 +50,7 @@ build() {
}
package() {
install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/src/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/src/beta.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${srcdir}/${pkgname}.git/src/dist/linux-unpacked/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.git/src/beta.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
} \ No newline at end of file
diff --git a/fsolauncher.sh b/fsolauncher.sh
index c77c53567639..0d20cddc70ca 100644
--- a/fsolauncher.sh
+++ b/fsolauncher.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file