summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-29 09:14:24 +0800
committerzxp198210052024-03-29 09:14:24 +0800
commit5dbefa5b130b19137f7f8b08fa6ade7b63b7b1bd (patch)
tree6d361cd933bec8f5658cfcfd1bbd98a7ce58b17b
parent0a3c93500b5409001ab3a9d85be25b467fc8bc09 (diff)
downloadaur-5dbefa5b130b19137f7f8b08fa6ade7b63b7b1bd.tar.gz
update to 1.38.42.r0.g876a1fd0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a68041ec3ba..e0f55476be81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fsolauncher
pkgdesc = Official FreeSO Launcher made with Electron
- pkgver = 1.10.4_prod.2
+ pkgver = 1.11.0_prod.1
pkgrel = 1
url = https://beta.freeso.org/
arch = x86_64
@@ -9,14 +9,14 @@ pkgbase = fsolauncher
makedepends = npm
makedepends = nvm
makedepends = git
- depends = electron22
+ depends = electron29
depends = nodejs
conflicts = fsolauncher
options = !strip
options = !emptydirs
- source = fsolauncher.git::git+https://github.com/ItsSim/fsolauncher.git#tag=1.10.4-prod.2
+ source = fsolauncher.git::git+https://github.com/ItsSim/fsolauncher.git#tag=1.11.0-prod.1
source = fsolauncher.sh
- sha256sums = c6378f82e2f3c274eb4173fc84eb4995e4745605f2c61ceb791f71407b0562aa
+ sha256sums = fd70fcbcc261f3931d0d27578f68d18b02bfd7e4cf1e7a7b60019f4abf1b2f0d
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = fsolauncher
diff --git a/PKGBUILD b/PKGBUILD
index 9bd3efea6949..60fe42e27d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=fsolauncher
_pkgname="FreeSO Launcher"
-pkgver=1.10.4_prod.2
-_electronversion=22
+pkgver=1.11.0_prod.1
+_electronversion=29
_nodeversion=16
pkgrel=1
pkgdesc="Official FreeSO Launcher made with Electron"
@@ -29,7 +29,7 @@ source=(
"${pkgname}.git::git+${_ghurl}.git#tag=${pkgver//_/-}"
"${pkgname}.sh"
)
-sha256sums=('c6378f82e2f3c274eb4173fc84eb4995e4745605f2c61ceb791f71407b0562aa'
+sha256sums=('fd70fcbcc261f3931d0d27578f68d18b02bfd7e4cf1e7a7b60019f4abf1b2f0d'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
_ensure_local_nvm() {
export NVM_DIR="${srcdir}/.nvm"
@@ -55,9 +55,9 @@ build() {
export npm_config_disturl=https://electronjs.org/headers
HOME="${srcdir}/.electron-gyp"
if [ `curl -s ipinfo.io/country | grep CN | wc -l ` -ge 1 ];then
- echo 'registry="https://registry.npmmirror.com/"' >> .npmrc
- echo 'electron_mirror="https://registry.npmmirror.com/-/binary/electron/"' >> .npmrc
- echo 'electron_builder_binaries_mirror="https://registry.npmmirror.com/-/binary/electron-builder-binaries/"' >> .npmrc
+ export npm_config_registry=https://registry.npmmirror.com
+ export npm_config_electron_mirror=https://registry.npmmirror.com/-/binary/electron/
+ export npm_config_electron_builder_binaries_mirror=https://registry.npmmirror.com/-/binary/electron-builder-binaries/
else
echo "Your network is OK."
fi