summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMort Yao2019-10-20 01:57:33 +0200
committerMort Yao2019-10-20 01:57:33 +0200
commitf705f3b623afa868566a40f52a4bbdd5438dc00d (patch)
tree4bf1c01428bad22899a850e8b634f146d06534d7
parent978875bf860a69a4db7b69392cd503f88501d086 (diff)
downloadaur-f705f3b623afa868566a40f52a4bbdd5438dc00d.tar.gz
fstar 0.9.7.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11fb5bea83b0..1faf3352c6d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri May 18 22:35:00 UTC 2018
+# Sat Oct 19 23:57:04 UTC 2019
pkgbase = fstar
pkgdesc = A Higher-Order Effectful Language Designed for Program Verification
- pkgver = 0.9.6.0
+ pkgver = 0.9.7.0
pkgrel = 1
url = https://fstar-lang.org/
arch = i686
@@ -10,6 +10,7 @@ pkgbase = fstar
license = Apache
makedepends = ocaml>=4.03
makedepends = ocaml-findlib
+ makedepends = ocaml-num
makedepends = ocaml-batteries
makedepends = ocaml-stdint
makedepends = zarith
@@ -17,6 +18,7 @@ pkgbase = fstar
makedepends = ocaml-fileutils
makedepends = ocaml-pprint
makedepends = ocaml-menhir
+ makedepends = ulex-git
makedepends = ocaml-migrate-parsetree
makedepends = ocaml-ppx_deriving
makedepends = ocaml-ppx_deriving_yojson
@@ -25,8 +27,8 @@ pkgbase = fstar
provides = fstar
conflicts = fstar-bin
conflicts = fstar-git
- source = https://github.com/FStarLang/FStar/archive/v0.9.6.0.zip
- md5sums = bad094857baf83b8f556ce1348d39ab4
+ source = https://github.com/FStarLang/FStar/archive/v0.9.7.0-alpha1.zip
+ md5sums = 754ecb3d2f6c234c78537707a87e6db2
pkgname = fstar
diff --git a/PKGBUILD b/PKGBUILD
index edffa0f3cbe0..202eb641e3cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: Mort Yao <soi@mort.ninja>
pkgname=fstar
-pkgver=0.9.6.0
+pkgver=0.9.7.0
+_subver=-alpha1
pkgrel=1
pkgdesc='A Higher-Order Effectful Language Designed for Program Verification'
url='https://fstar-lang.org/'
license=('Apache')
arch=('i686' 'x86_64')
depends=('z3-git')
-makedepends=('ocaml>=4.03' 'ocaml-findlib' 'ocaml-batteries' 'ocaml-stdint' 'zarith' 'ocaml-yojson' 'ocaml-fileutils' 'ocaml-pprint' 'ocaml-menhir' 'ocaml-migrate-parsetree' 'ocaml-ppx_deriving' 'ocaml-ppx_deriving_yojson' 'ocaml-process')
+makedepends=('ocaml>=4.03' 'ocaml-findlib' 'ocaml-num' 'ocaml-batteries' 'ocaml-stdint' 'zarith' 'ocaml-yojson' 'ocaml-fileutils' 'ocaml-pprint' 'ocaml-menhir' 'ulex-git' 'ocaml-migrate-parsetree' 'ocaml-ppx_deriving' 'ocaml-ppx_deriving_yojson' 'ocaml-process')
provides=('fstar')
conflicts=('fstar-bin' 'fstar-git')
-source=("https://github.com/FStarLang/FStar/archive/v$pkgver.zip")
-md5sums=('bad094857baf83b8f556ce1348d39ab4')
+source=("https://github.com/FStarLang/FStar/archive/v$pkgver$_subver.zip")
+md5sums=('754ecb3d2f6c234c78537707a87e6db2')
build() {
- cd "FStar-$pkgver"
+ cd "FStar-$pkgver$_subver"
# Step 3. Building F* from the OCaml snapshot
make -C src/ocaml-output -j 3
}
package() {
- cd "FStar-$pkgver"
+ cd "FStar-$pkgver$_subver"
install -d -m755 $pkgdir/opt/fstar $pkgdir/usr/bin
cp -r * $pkgdir/opt/fstar