summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrobinleander2018-07-27 11:30:11 +0200
committerrobinleander2018-07-27 11:30:48 +0200
commit0038b87cda3148d7398789ce2decc63f3b14ff54 (patch)
tree071230e619c84d6287be2e4f87ebbe9b5ab8e6f6
downloadaur-0038b87cda3148d7398789ce2decc63f3b14ff54.tar.gz
Initial release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed4e0c655979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fstar-ulib
+ pkgdesc = compiles the ulib component of F*
+ pkgver = 0.9.6.0
+ pkgrel = 1
+ url = https://www.fstar-lang.org/
+ arch = i686
+ arch = x86_64
+ license = Apache-2.0
+ depends = fstar
+ options = !strip
+ options = !makeflags
+ options = staticlibs
+
+pkgname = fstar-ulib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cbdbc6707628
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: crave <crave@noreply.org>
+
+pkgname=fstar-ulib
+pkgver=0.9.6.0
+pkgrel=1
+pkgdesc="compiles the ulib component of F*"
+arch=('i686' 'x86_64')
+url='https://www.fstar-lang.org/'
+license=('Apache-2.0')
+options=('!strip' '!makeflags' 'staticlibs')
+depends=('fstar')
+
+build() {
+ cd "$srcdir/"
+ cp -r /opt/fstar fstar
+ export FSTAR_HOME="$(pwd)/fstar"
+ cd fstar
+ make
+}
+
+package() {
+ install -dm 755 "fstar/ulib"
+}