summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsomeoneelse2022-06-30 18:02:20 +0200
committersomeoneelse2022-06-30 18:02:55 +0200
commit62e18bdcd9999304d63dbb1d5eb293bde32667dc (patch)
treea1c7b07593a8212c60e2ded577ec488b06913cdf
parent3a082bd978754ef9c9d9fd656543ea52ee9c6535 (diff)
downloadaur-62e18bdcd9999304d63dbb1d5eb293bde32667dc.tar.gz
v0.10.0
switches to cmake https://wiki.archlinux.org/title/CMake_package_guidelines#Template > arch=('any') indicates the package can be built once on any architecture, > and once built, is architecture-independent in its compiled state which is definitely not the case here it almost surely builds on more than just x86_64 but I haven't tested those recently (armhf used to work, at least)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94a997dd1411..d6dc2cada0f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = fstl
pkgdesc = A viewer for .stl files
- pkgver = 0.9.4
+ pkgver = 0.10.0
pkgrel = 1
url = http://www.mattkeeter.com/projects/fstl/
- arch = any
+ arch = x86_64
license = MIT
makedepends = icoutils
+ makedepends = cmake
depends = qt5-base
- source = https://github.com/mkeeter/fstl/archive/v0.9.4.tar.gz
+ source = https://github.com/mkeeter/fstl/archive/v0.10.0.tar.gz
source = fstl.desktop
- sha256sums = 5c2d6bf14ec0bee15d415a0810787bfd714971822a4fa9433c6ea476484dd335
+ sha256sums = e00c9f5f90e5efc3804cd2d7a64efb9f592921b7ff78d7190aa4182145119d9a
sha256sums = 53d2a7911cacc1ca8e9fe823e8ecf2777c1158f51d2b909ebb106d976c70bec5
pkgname = fstl
-
diff --git a/PKGBUILD b/PKGBUILD
index 2e7059741e99..867395ba262c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: someoneelse <lllusion3418@gmail.com>
pkgname=fstl
-pkgver=0.9.4
+pkgver=0.10.0
pkgrel=1
pkgdesc="A viewer for .stl files"
url="http://www.mattkeeter.com/projects/fstl/"
-arch=('any')
+arch=('x86_64')
license=('MIT')
depends=('qt5-base')
-makedepends=("icoutils")
+makedepends=("icoutils" "cmake")
source=("https://github.com/mkeeter/fstl/archive/v${pkgver}.tar.gz"
"fstl.desktop")
-sha256sums=('5c2d6bf14ec0bee15d415a0810787bfd714971822a4fa9433c6ea476484dd335'
+sha256sums=('e00c9f5f90e5efc3804cd2d7a64efb9f592921b7ff78d7190aa4182145119d9a'
'53d2a7911cacc1ca8e9fe823e8ecf2777c1158f51d2b909ebb106d976c70bec5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
-
- mkdir -p build
- pushd build
- qmake-qt5 PREFIX="/usr" ../qt/fstl.pro
- make
- popd
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ cmake --build build
sed -n '/Copyright/,/PROVIDED/p' README.md > LICENSE
@@ -32,10 +31,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- pushd "build"
- make INSTALL_ROOT="${pkgdir}" install
- install -Dm755 fstl "${pkgdir}/usr/bin/fstl"
- popd
+ DESTDIR="$pkgdir" cmake --install build
install -D -m644 fstl.png "${pkgdir}/usr/share/pixmaps/fstl.png"