summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessandro Pazzaglia2015-06-08 19:41:35 +0200
committerAlessandro Pazzaglia2015-06-08 19:41:35 +0200
commit3a7556c7699d72d48113d0d39291c53cf6780ec9 (patch)
tree55ed01dc47d1b2b2a24bb399778170d84a938a4d
downloadaur-3a7556c7699d72d48113d0d39291c53cf6780ec9.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
-rw-r--r--patch_gcc5_svn_r2472.diff123
3 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1cbb6c11c01e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.1
+# Wed May 27 19:20:15 UTC 2015
+pkgbase = fsvs
+ pkgdesc = A fast system versioning tool via subversion backend
+ pkgver = 1.2.5
+ pkgrel = 2
+ url = http://fsvs.tigris.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = pcre
+ depends = subversion
+ options = !buildflags
+ source = http://download.fsvs-software.org/fsvs-1.2.5.tar.bz2
+ source = patch_gcc5_svn_r2472.diff
+ md5sums = d9c99d27b26e3edd48a6fd77c9f071ef
+ md5sums = 27df7da37de1af603822236fcf75384b
+
+pkgname = fsvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b780eb45df98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Submitter: TDY <tdy@archlinux.info>
+# Maintainer: Alessandro Pazzaglia <jackdroido at gmail dot com>
+
+pkgname=fsvs
+pkgver=1.2.5
+pkgrel=2
+pkgdesc="A fast system versioning tool via subversion backend"
+arch=('i686' 'x86_64')
+url="http://fsvs.tigris.org/"
+license=('GPL3')
+depends=('pcre' 'subversion')
+options=('!buildflags')
+source=(http://download.$pkgname-software.org/$pkgname-$pkgver.tar.bz2
+ patch_gcc5_svn_r2472.diff)
+md5sums=('d9c99d27b26e3edd48a6fd77c9f071ef'
+ '27df7da37de1af603822236fcf75384b')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch -Np0 < ../../patch_gcc5_svn_r2472.diff
+ LDFLAGS="/usr/lib/libdl.so.2 -Wl,-z,noexecstack" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 src/$pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 doc/$pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -Dm644 doc/$pkgname-groups.5 "$pkgdir/usr/share/man/man5/$pkgname-groups.5"
+ install -cm644 doc/$pkgname-{h,o,u}*.5 "$pkgdir/usr/share/man/man5/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/patch_gcc5_svn_r2472.diff b/patch_gcc5_svn_r2472.diff
new file mode 100644
index 000000000000..5c55e7f554e4
--- /dev/null
+++ b/patch_gcc5_svn_r2472.diff
@@ -0,0 +1,123 @@
+--- src/props.h (revision 2471)
++++ src/props.h (revision 2472)
+@@ -36,7 +36,7 @@
+ /** Set a property by name and data/datalen. */
+ int prp__set(hash_t db, const char *name, const char *data, int datalen);
+ /** Set a property by svn_string_t. */
+-inline int prp__set_svnstr(hash_t db,
++int prp__set_svnstr(hash_t db,
+ const char *name,
+ const svn_string_t *utf8_value);
+
+--- src/est_ops.c (revision 2471)
++++ src/est_ops.c (revision 2472)
+@@ -499,7 +499,7 @@
+ [sizeof(buffer)-1]=0xff,
+ [sizeof(buffer)-2]=0x0,
+ };
+- int is_dir, is_dev, status, is_spec;
++ int is_dir, is_dev, status;
+ int intnum;
+
+
+@@ -518,8 +518,6 @@
+
+ is_dir = S_ISDIR(sts->st.mode);
+ is_dev = S_ISBLK(sts->st.mode) || S_ISCHR(sts->st.mode);
+- is_spec = S_ISBLK(sts->st.mode) || S_ISCHR(sts->st.mode) ||
+- S_ISLNK(sts->st.mode);
+
+
+ if (sts->match_pattern)
+--- src/diff.c (revision 2471)
++++ src/diff.c (revision 2472)
+@@ -721,7 +721,7 @@
+ int status;
+ struct estat **sts;
+ int removed;
+- char *fn, *special_stg;
++ char *fn;
+ apr_pool_t *subpool;
+
+
+@@ -774,8 +774,6 @@
+ else if (entry->entry_status || entry->remote_status)
+ {
+ /* Local changes, or changes to repository. */
+- special_stg=NULL;
+-
+ if (S_ISDIR(entry->st.mode))
+ {
+ /* TODO: meta-data diff? */
+--- src/waa.c (revision 2471)
++++ src/waa.c (revision 2472)
+@@ -121,7 +121,7 @@
+
+
+ /** Convenience function for creating two paths. */
+-inline void waa___init_path(enum opt__settings_e which,
++static inline void waa___init_path(enum opt__settings_e which,
+ char *dest, char **eos)
+ {
+ int l;
+@@ -1824,7 +1824,7 @@
+ * - it was freshly added.
+ *
+ * */
+-inline int waa___check_dir_for_update(struct estat *sts)
++static inline int waa___check_dir_for_update(struct estat *sts)
+ {
+ int status;
+
+@@ -2738,7 +2738,7 @@
+
+
+ /** Abbreviation function for tree recursion. */
+-inline int waa___recurse_tree(struct estat **list, action_t handler,
++static inline int waa___recurse_tree(struct estat **list, action_t handler,
+ int (*me)(struct estat *, action_t ))
+ {
+ struct estat *sts;
+--- src/racallback.c (revision 2471)
++++ src/racallback.c (revision 2472)
+@@ -42,6 +42,7 @@
+ char *cfg_usr_path;
+
+
++ cfg_usr_path = NULL;
+ STOPIF( hlp__get_svn_config(&cfg_hash), NULL);
+
+ cfg = apr_hash_get(cfg_hash, SVN_CONFIG_CATEGORY_CONFIG,
+--- src/cache.c (revision 2471)
++++ src/cache.c (revision 2472)
+@@ -46,7 +46,7 @@
+ *
+ * Please note that memory may have to be reallocated, causing \c *cache to
+ * change! */
+-inline int cch__entry_set(struct cache_entry_t **cache,
++int cch__entry_set(struct cache_entry_t **cache,
+ cache_value_t id, const char *data, int len,
+ int copy_old_data,
+ char **copy)
+--- src/cache.h (revision 2471)
++++ src/cache.h (revision 2472)
+@@ -94,7 +94,7 @@
+ int *index, char **data, int *len);
+
+ /** Copy the given data into the given cache entry. */
+-inline int cch__entry_set(struct cache_entry_t **cache,
++int cch__entry_set(struct cache_entry_t **cache,
+ cache_value_t id, const char *data, int len,
+ int copy_old_data,
+ char **copy);
+--- src/helper.c (revision 2471)
++++ src/helper.c (revision 2472)
+@@ -84,7 +84,7 @@
+ * \note If there's an irreparable conversion error, we must not print
+ * (parts of) the strings. One or even both might not be suitable for
+ * printing on the current console - so we do not know what could happen. */
+-inline int hlp___do_convert(iconv_t cd,
++static inline int hlp___do_convert(iconv_t cd,
+ const char* from, char** to,
+ int len)
+ {