summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-02-09 13:04:32 +0100
committeraksr2016-02-09 13:04:32 +0100
commit997bceeaa877a0e34ca28c8ce40df8ccfe8e0d16 (patch)
tree12285b698e018f3ce2e30371d5f603a58c33c87a
downloadaur-997bceeaa877a0e34ca28c8ce40df8ccfe8e0d16.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca271ff67b97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Feb 9 12:04:32 UTC 2016
+pkgbase = fswatch-git
+ pkgdesc = A file change monitor that receives notifications when the contents of the specified files or directories are modified.
+ pkgver = 1.8.0.r0.gcda2487
+ pkgrel = 1
+ url = https://emcrisostomo.github.io/fswatch/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ provides = fswatch
+ conflicts = fswatch
+ source = fswatch-git::git+https://github.com/emcrisostomo/fswatch.git
+ md5sums = SKIP
+
+pkgname = fswatch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bea55042ab9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=fswatch-git
+pkgver=1.8.0.r0.gcda2487
+pkgrel=1
+epoch=
+pkgdesc="A file change monitor that receives notifications when the contents of the specified files or directories are modified."
+arch=('i686' 'x86_64')
+url="https://github.com/emcrisostomo/fswatch"
+url="https://emcrisostomo.github.io/fswatch/"
+license=('GPLv3')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=('fswatch')
+conflicts=('fswatch')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/emcrisostomo/fswatch.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname"
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+