summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2017-09-12 21:48:06 +0200
committerJelle van der Waa2017-09-12 21:48:06 +0200
commit3cb6930ef831207c7415134010a33179093acbbe (patch)
tree96fd358b4e2edc0783278593cf7c8f0bed13cdee
downloadaur-3cb6930ef831207c7415134010a33179093acbbe.tar.gz
moved from [community]
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c275a241782
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 5.0.2
+# Tue Sep 12 19:47:08 UTC 2017
+pkgbase = fswebcam
+ pkgdesc = Tiny and flexible webcam app.
+ pkgver = 20140113
+ pkgrel = 1
+ url = http://www.firestorm.cx/fswebcam
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gd
+ backup = etc/fswebcam.conf
+ source = http://www.firestorm.cx/fswebcam/files/fswebcam-20140113.tar.xz
+ md5sums = 1bfdb21904e816f100370ec8f4df986b
+ sha1sums = 6c1f3e3c8cf3189f0e2a5d4f8c9534c855c02e0a
+
+pkgname = fswebcam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7e7c5f3b739
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 105614 2014-02-11 18:34:38Z ttoepper $
+# Maintainer: Thorsten Töpper <atsutane-tu@freethoughts.de>
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Philipp Robbel <robbel@gmail.com>
+
+pkgname=fswebcam
+pkgver=20140113
+pkgrel=1
+pkgdesc="Tiny and flexible webcam app."
+arch=('i686' 'x86_64')
+url="http://www.firestorm.cx/fswebcam"
+license=('GPL')
+depends=('gd')
+backup=("etc/$pkgname.conf")
+source=("$url/files/$pkgname-$pkgver.tar.xz")
+md5sums=('1bfdb21904e816f100370ec8f4df986b')
+sha1sums=('6c1f3e3c8cf3189f0e2a5d4f8c9534c855c02e0a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ # Install configuration file
+ # Commented to avoid problems with many devices, thank you SpepS
+ sed "s_^_#_g" -i example.conf
+ install -Dm644 example.conf "$pkgdir/etc/fswebcam.conf"
+}
+
+# vim:ts=2:sw=2:expandtab