summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2017-10-23 15:53:03 -0700
committerGavin Lloyd2017-10-23 15:53:43 -0700
commita26c3ddb7a62968591974be392738e414ef4c199 (patch)
tree303dfb8efb2385089484941d4d21684f29aeac63
parent3cb6930ef831207c7415134010a33179093acbbe (diff)
downloadaur-a26c3ddb7a62968591974be392738e414ef4c199.tar.gz
Update URL, cleanup
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 22 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c275a241782..7f126a8691b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
-# Generated by makepkg 5.0.2
-# Tue Sep 12 19:47:08 UTC 2017
+# Generated by mksrcinfo v8
+# Mon Oct 23 22:53:26 UTC 2017
pkgbase = fswebcam
- pkgdesc = Tiny and flexible webcam app.
+ pkgdesc = Neat and simple webcam app
pkgver = 20140113
- pkgrel = 1
- url = http://www.firestorm.cx/fswebcam
+ pkgrel = 2
+ url = https://www.sanslogic.co.uk/fswebcam/
arch = i686
arch = x86_64
- license = GPL
+ license = GPL2
depends = gd
backup = etc/fswebcam.conf
- source = http://www.firestorm.cx/fswebcam/files/fswebcam-20140113.tar.xz
- md5sums = 1bfdb21904e816f100370ec8f4df986b
- sha1sums = 6c1f3e3c8cf3189f0e2a5d4f8c9534c855c02e0a
+ source = https://www.sanslogic.co.uk/fswebcam//files/fswebcam-20140113.tar.gz
+ sha256sums = 3ee389f72a7737700d22e0c954720b1e3bbadc8a0daad6426c25489ba9dc3199
pkgname = fswebcam
diff --git a/PKGBUILD b/PKGBUILD
index b7e7c5f3b739..99bdda00c80d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,32 @@
-# $Id: PKGBUILD 105614 2014-02-11 18:34:38Z ttoepper $
-# Maintainer: Thorsten Töpper <atsutane-tu@freethoughts.de>
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Thorsten Töpper <atsutane-tu@freethoughts.de>
# Contributor: SpepS <dreamspepser at yahoo dot it>
# Contributor: Philipp Robbel <robbel@gmail.com>
pkgname=fswebcam
pkgver=20140113
-pkgrel=1
-pkgdesc="Tiny and flexible webcam app."
+pkgrel=2
+pkgdesc='Neat and simple webcam app'
arch=('i686' 'x86_64')
-url="http://www.firestorm.cx/fswebcam"
-license=('GPL')
+url="https://www.sanslogic.co.uk/fswebcam/"
+license=('GPL2')
depends=('gd')
-backup=("etc/$pkgname.conf")
-source=("$url/files/$pkgname-$pkgver.tar.xz")
-md5sums=('1bfdb21904e816f100370ec8f4df986b')
-sha1sums=('6c1f3e3c8cf3189f0e2a5d4f8c9534c855c02e0a')
+backup=("etc/${pkgname}.conf")
+source=("${url}/files/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('3ee389f72a7737700d22e0c954720b1e3bbadc8a0daad6426c25489ba9dc3199')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="${pkgdir}" install
- # Install configuration file
- # Commented to avoid problems with many devices, thank you SpepS
- sed "s_^_#_g" -i example.conf
- install -Dm644 example.conf "$pkgdir/etc/fswebcam.conf"
+ sed -ri 's/^([^#])/#\1/g' example.conf
+ install -Dm644 example.conf "${pkgdir}"/etc/fswebcam.conf
}
-
-# vim:ts=2:sw=2:expandtab