summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gentilucci2019-06-17 20:44:35 -0600
committerAlex Gentilucci2019-06-17 20:44:35 -0600
commit2278b60be6db392e4ebd3b688662a7e4bbb200ae (patch)
tree7abb0e6dec7985e81a28158ca35b0215fcfb58ff
downloadaur-2278b60be6db392e4ebd3b688662a7e4bbb200ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD27
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b3278a0af4e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ft2-clone
+ pkgdesc = A portable Fasttracker II clone written in C.
+ pkgver = b159
+ pkgrel = 1
+ url = https://16-bits.org/ft2.php
+ arch = x86_64
+ license = BSD
+ makedepends = gcc
+ depends = alsa-lib
+ depends = sdl2
+ source = https://16-bits.org/ft2clone-b159-code.zip
+ sha512sums = 3a53ac32a15742eb1d4bacf0c1906cbf96c81e7f13d9bcdd5e6907fb1d393c46353afd7da651148f3e54da866737ad5b5e95cb3edd63579eee3d6a7aedece3af
+
+pkgname = ft2-clone
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ca12330e9164
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tgz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a6750aac878
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
+pkgname=ft2-clone
+pkgver=b159
+pkgrel=1
+epoch=
+pkgdesc="A portable Fasttracker II clone written in C."
+arch=('x86_64')
+url="https://16-bits.org/ft2.php"
+license=('BSD')
+makedepends=('gcc')
+depends=('alsa-lib' 'sdl2')
+source=("https://16-bits.org/ft2clone-$pkgver-code.zip")
+sha512sums=('3a53ac32a15742eb1d4bacf0c1906cbf96c81e7f13d9bcdd5e6907fb1d393c46353afd7da651148f3e54da866737ad5b5e95cb3edd63579eee3d6a7aedece3af')
+
+build() {
+ cd "$srcdir/$pkgname-code"
+
+ # If you're compiling for *SLOW* devices, try adding -DLERPMIX right after gcc
+ # This will activate 2-tap linear interpolation mixing (blurrier sound) instead
+ # of 3-tap quadratic interpolation mixing (sharper sound)
+ gcc -D__LINUX_ALSA__ src/rtmidi/*.cpp src/gfxdata/*.c src/*.c -lSDL2 -lpthread -lasound -lstdc++ -lm -Wshadow -Winit-self -Wall -mno-ms-bitfields -Wno-stringop-truncation -Wno-missing-field-initializers -Wno-unused-result -Wno-strict-aliasing -Wextra -Wunused -Wunreachable-code -Wswitch-default -march=native -mtune=native -O3 -o release/other/ft2-clone
+}
+
+package() {
+ install -D -m 755 "$srcdir/$pkgname-code/release/other/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname-code/src/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}