summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-01-11 02:48:07 +0100
committerNarrat2020-01-11 02:48:07 +0100
commit530d78bfb5386af90918638635f88181db4567ba (patch)
tree27837e8f2ee6357d3f55900837e677edb958464d
parent45dccdce85e2fa5f016e4738a8c9c40432fe72bf (diff)
downloadaur-530d78bfb5386af90918638635f88181db4567ba.tar.gz
Update to 1.05...
... and change the way the source is downloaded. Which means, it now uses the github repo to retrieve the source. GCC is a base-devel package, which aren't added as deps
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 22 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d56374c553a5..e54987d901eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
pkgbase = ft2-clone
- pkgdesc = A portable Fasttracker II clone written in C
- pkgver = 1.00
+ pkgdesc = portable Fasttracker II clone written in C
+ pkgver = 1.05
pkgrel = 1
url = https://16-bits.org/ft2.php
arch = x86_64
license = BSD
- makedepends = gcc
makedepends = libicns
- makedepends = unzip
depends = alsa-lib
depends = sdl2
- source = https://16-bits.org/ft2.php
+ source = ft2-clone-1.05.tar.gz::https://github.com/8bitbubsy/ft2-clone/archive/v1.05.tar.gz
source = ft2-clone.desktop
- md5sums = SKIP
- md5sums = SKIP
+ md5sums = ef299e7be29df4a4b43659323df3e3c3
+ md5sums = aabdeb67ba116ea9e7937ff551aeb837
pkgname = ft2-clone
diff --git a/PKGBUILD b/PKGBUILD
index 32a3b912042e..acc1359fb467 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,35 @@
-# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: Alex Gentilucci <alexander.gentilucci@gmail.com>
+
pkgname=ft2-clone
-pkgver=1.00
+pkgver=1.05
pkgrel=1
-pkgdesc="A portable Fasttracker II clone written in C"
+pkgdesc="portable Fasttracker II clone written in C"
arch=('x86_64')
url="https://16-bits.org/ft2.php"
license=("BSD")
-makedepends=("gcc" "libicns" "unzip")
+makedepends=("libicns")
depends=("alsa-lib" "sdl2")
-source=("https://16-bits.org/ft2.php" "ft2-clone.desktop")
-md5sums=("SKIP" "SKIP")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/8bitbubsy/ft2-clone/archive/v${pkgver}.tar.gz"
+ "ft2-clone.desktop")
+md5sums=('ef299e7be29df4a4b43659323df3e3c3'
+ 'aabdeb67ba116ea9e7937ff551aeb837')
-pkgver() {
- grep -oP "(?<=ft2-clone-v)([0-9]+\.[0-9]+)(?=-code\.zip)" ft2.php | head -n 1
-}
prepare() {
- name=$(grep -oE "(ft2-clone-v)([0-9]+\.[0-9]+)(-code\.zip)" ft2.php | head -n 1)
- curl -O "https://16-bits.org/$name"
- unzip $name
+ cd "$pkgname-$pkgver"
+ icns2png -x "release/macos/ft2-clone-macos.app/Contents/Resources/ft2-clone-macos.icns"
+ chmod +x "make-linux.sh"
}
build() {
- cd "$pkgname-code"
- icns2png -x "release/macos/ft2-clone-macos.app/Contents/Resources/ft2-clone-macos.icns"
- chmod +x "make-linux.sh"
+ cd "$pkgname-$pkgver"
./make-linux.sh
}
package() {
- install -D -m 755 "$pkgname-code/release/other/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$pkgname-code/src/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m 755 "$pkgname-$pkgver/release/other/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname-$pkgver/src/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "ft2-clone.desktop" "$pkgdir/usr/share/applications/ft2-clone.desktop"
- install -Dm644 "$pkgname-code/ft2-clone-macos_256x256x32.png" "$pkgdir/usr/share/pixmaps/ft2-clone.png"
+ install -Dm644 "$pkgname-$pkgver/ft2-clone-macos_256x256x32.png" "$pkgdir/usr/share/pixmaps/ft2-clone.png"
}