summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Gentilucci2019-08-24 08:40:03 -0600
committerAlex Gentilucci2019-08-24 08:40:03 -0600
commitb7e3e448c15193a1924fc043a82f9ae79ca27b77 (patch)
treee477f8d1df1158cdbe598a2ef6a54d66768b2e4b
parent99a35d161d9465e5244fa29285d6a6733601104d (diff)
downloadaur-b7e3e448c15193a1924fc043a82f9ae79ca27b77.tar.gz
Added auto-updates, courtesy of cylgom
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD47
2 files changed, 31 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1315ce914128..d89096c26531 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = ft2-clone
- pkgdesc = A portable Fasttracker II clone written in C.
- pkgver = b162
+ pkgdesc = A portable Fasttracker II clone written in C
+ pkgver = b166
pkgrel = 1
url = https://16-bits.org/ft2.php
arch = x86_64
license = BSD
makedepends = gcc
makedepends = libicns
+ makedepends = unzip
depends = alsa-lib
depends = sdl2
- source = https://16-bits.org/ft2clone-b162-code.zip
+ source = https://16-bits.org/ft2.php
source = ft2-clone.desktop
- sha512sums = 4b85514aece028075e8e5017c3b0c26638f0c74e18ac669788393a03457cb903959a548de9b1ca249eab8e629e18503dd1a7519aa81645a26e8f25684c4ec817
- sha512sums = e095a21dd5165b130426b3df0735f00b34694ea3eb5b0b93699d89cb503b3fd0cff7b15f214d123643a0c323e988185fdfbf5452e971970957cebd4a5da1033e
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = ft2-clone
diff --git a/PKGBUILD b/PKGBUILD
index f54f48283098..7814c3f6c032 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: Alex Gentilucci <alexander.gentilucci@gmail.com>
pkgname=ft2-clone
-pkgver=b162
+pkgver=b166
pkgrel=1
-epoch=
-pkgdesc="A portable Fasttracker II clone written in C."
+pkgdesc="A portable Fasttracker II clone written in C"
arch=('x86_64')
url="https://16-bits.org/ft2.php"
-license=('BSD')
-makedepends=('gcc' 'libicns')
-depends=('alsa-lib' 'sdl2')
-source=("https://16-bits.org/ft2clone-$pkgver-code.zip"
- "ft2-clone.desktop")
-sha512sums=('4b85514aece028075e8e5017c3b0c26638f0c74e18ac669788393a03457cb903959a548de9b1ca249eab8e629e18503dd1a7519aa81645a26e8f25684c4ec817'
- 'e095a21dd5165b130426b3df0735f00b34694ea3eb5b0b93699d89cb503b3fd0cff7b15f214d123643a0c323e988185fdfbf5452e971970957cebd4a5da1033e')
+license=("BSD")
+makedepends=("gcc" "libicns" "unzip")
+depends=("alsa-lib" "sdl2")
+source=("https://16-bits.org/ft2.php" "ft2-clone.desktop")
+md5sums=("SKIP" "SKIP")
-build() {
- cd "$srcdir/$pkgname-code"
-
- icns2png -x "release/macos/ft2-osx.app/Contents/Resources/ft2-osx.icns"
+pkgver() {
+ grep -oP "(?<=ft2clone-)([a-z]+[0-9]+)(?=-code\.zip)" ft2.php | head -n 1
+}
- # If you're compiling for *SLOW* devices, try adding -DLERPMIX right after gcc
- # This will activate 2-tap linear interpolation mixing (blurrier sound) instead
- # of 3-tap quadratic interpolation mixing (sharper sound)
- gcc -D__LINUX_ALSA__ src/rtmidi/*.cpp src/gfxdata/*.c src/*.c -lSDL2 -lpthread -lasound -lstdc++ -lm -Wshadow -Winit-self -Wall -mno-ms-bitfields -Wno-stringop-truncation -Wno-missing-field-initializers -Wno-unused-result -Wno-strict-aliasing -Wextra -Wunused -Wunreachable-code -Wswitch-default -march=native -mtune=native -O3 -o release/other/ft2-clone
+prepare() {
+ name=$(grep -oE "ft2clone-[a-z]+[0-9]+-code\.zip" ft2.php | head -n 1)
+ curl -O "https://16-bits.org/$name"
+ unzip $name
+}
+
+build() {
+ cd "$pkgname-code"
+ icns2png -x "release/macos/ft2-osx.app/Contents/Resources/ft2-osx.icns"
+ chmod +x "make-linux.sh"
+ ./make-linux.sh
}
package() {
- install -D -m 755 "$srcdir/$pkgname-code/release/other/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$srcdir/$pkgname-code/src/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "$srcdir/ft2-clone.desktop" "$pkgdir/usr/share/applications/ft2-clone.desktop"
- install -Dm644 "$srcdir/$pkgname-code/ft2-osx_256x256x32.png" "$pkgdir/usr/share/pixmaps/ft2-clone.png"
+ install -D -m 755 "$pkgname-code/release/other/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$pkgname-code/src/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "ft2-clone.desktop" "$pkgdir/usr/share/applications/ft2-clone.desktop"
+ install -Dm644 "$pkgname-code/ft2-osx_256x256x32.png" "$pkgdir/usr/share/pixmaps/ft2-clone.png"
}