summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsu2262022-08-16 18:43:03 +0800
committersu2262022-08-16 18:43:03 +0800
commit0ed225cabd366349b053357e4cf19f29822583f0 (patch)
tree2c44e815787750a93842f3c53fa661015ace223d
parent8039de129298f605029b8d7941a0d350dfb25c67 (diff)
downloadaur-0ed225cabd366349b053357e4cf19f29822583f0.tar.gz
Bump to 202208131844_e5790011d3_release and keep the same structure with ftba-electron
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
-rwxr-xr-xftb-app.desktop6
-rwxr-xr-xftbapp.desktop7
4 files changed, 38 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 396490d19be9..c341350bd440 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = ftba
pkgdesc = Offers many different styles of Minecraft modpacks to the community.
- pkgver = 202207271710_0f9644f5fc_release
+ pkgver = 202208131844_e5790011d3_release
pkgrel = 1
url = https://feed-the-beast.com/app
arch = any
license = LGPL2.1
- depends = java-runtime=8
- depends = java-runtime=11
depends = java-runtime=17
depends = avahi
- optdepends = jdk8-graalvm-bin: improved performance with '-XX:+UseJVMCICompiler'
- source = https://apps.modpacks.ch/FTBApp/release/202207271710-0f9644f5fc-release/FTBA_linux_202207271710-0f9644f5fc-release.deb
- source = ftbapp.desktop
- sha256sums = ce87521fedcd0f6ede3f9408a44ac6fe48723d8a2c81105131c3ccdcb1217c32
- sha256sums = 72e6e0b01e790e416ab1ac215b7179f968156d10be5b36fad656a4f084778db6
+ optdepends = java-runtime=11: For playing some version of Minecraft with system Java.
+ optdepends = java-runtime=8: For playing some version of Minecraft with system Java.
+ source = https://apps.modpacks.ch/FTBApp/release/202208131844-e5790011d3-release/FTBA_linux_202208131844-e5790011d3-release.deb
+ source = ftb-app.desktop
+ sha256sums = 52b771025d09e327a55b26a86570e6cdc3c8428cdd8b0c93a9659b7405d9349f
+ sha256sums = 2b50da4dc2811b175e5602e91dfe18e981cba3e2e80deccb8f12b59776d8c530
pkgname = ftba
diff --git a/PKGBUILD b/PKGBUILD
index 99d169d4d8d9..f8c0e2b1baae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,38 @@
# Contributor: alphRomeo323 <alpharomeo323dev at protonmail dot com>
# Contributor: William Brown <glowinthedarkcia at horsefucker dot org>
pkgname=ftba
-pkgver=202207271710_0f9644f5fc_release
+pkgver=202208131844_e5790011d3_release
pkgrel=1
url="https://feed-the-beast.com/app"
arch=(any)
pkgdesc="Offers many different styles of Minecraft modpacks to the community."
-source=("https://apps.modpacks.ch/FTBApp/release/${pkgver//_/-}/FTBA_linux_${pkgver//_/-}.deb" "ftbapp.desktop")
-sha256sums=('ce87521fedcd0f6ede3f9408a44ac6fe48723d8a2c81105131c3ccdcb1217c32'
- '72e6e0b01e790e416ab1ac215b7179f968156d10be5b36fad656a4f084778db6')
-license=('LGPL2.1')
-depends=("java-runtime=8" "java-runtime=11" "java-runtime=17" "avahi") # Crashes without libavahi-common.so.3
-optdepends=("jdk8-graalvm-bin: improved performance with '-XX:+UseJVMCICompiler'")
+source=("https://apps.modpacks.ch/FTBApp/release/${pkgver//_/-}/FTBA_linux_${pkgver//_/-}.deb"
+ "ftb-app.desktop")
+sha256sums=("52b771025d09e327a55b26a86570e6cdc3c8428cdd8b0c93a9659b7405d9349f"
+ "2b50da4dc2811b175e5602e91dfe18e981cba3e2e80deccb8f12b59776d8c530")
+license=("LGPL2.1")
+depends=("java-runtime=17" "avahi") # Crashes without libavahi-common.so.3
+# FTBA will download Adoptium for Minecraft, although system Java can be used too.
+optdepends=("java-runtime=11: For playing some version of Minecraft with system Java."
+ "java-runtime=8: For playing some version of Minecraft with system Java.")
package() {
- cd "$pkgdir"
- tar -xzf "$srcdir/data.tar.gz"
- mkdir -p usr/{bin,share/applications}
- cp "$srcdir/ftbapp.desktop" usr/share/applications
+ cd "$pkgdir"
+ tar -xzf "$srcdir/data.tar.gz"
- # remove windows and apple specific files
- rm -R opt/FTBA/bin/{ftbapp.app,{,**/}*.{exe,dll}}
+ mkdir -p usr/{bin,lib,share/applications,share/icons/hicolor/512x512/apps}
+ cp "$srcdir/ftb-app.desktop" usr/share/applications
- # remove bundled jre, java-runtime=11 is dependency.
- rm -R opt/FTBA/jre
+ # remove windows and apple specific files
+ rm -R opt/FTBA/bin/{ftbapp.app,{,**/}*.{exe,dll}}
- chmod +x opt/FTBA/bin/ftb-app
- ln -rs ./opt/FTBA/FTBApp ./usr/bin
+ # remove bundled jre, java-runtime=17 is dependency.
+ rm -R opt/FTBA/jre
+
+ # Do not install to /opt
+ mv opt/FTBA usr/lib/ftb-app
+ chmod +x usr/lib/ftb-app/bin/ftb-app
+ mv usr/lib/ftb-app/FTBApp usr/lib/ftb-app/ftb-app
+ cp usr/lib/ftb-app/.install4j/FTBApp.png usr/share/icons/hicolor/512x512/apps/ftb-app.png
+ ln -s /usr/lib/ftb-app/ftb-app usr/bin/ftb-app
}
diff --git a/ftb-app.desktop b/ftb-app.desktop
new file mode 100755
index 000000000000..853be69db200
--- /dev/null
+++ b/ftb-app.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=FTB Desktop App
+Exec=/usr/bin/ftb-app
+Icon=ftb-app
+Categories=Game;
diff --git a/ftbapp.desktop b/ftbapp.desktop
deleted file mode 100755
index e5a69c4ff28c..000000000000
--- a/ftbapp.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/usr/bin/env xdg-open
-[Desktop Entry]
-Type=Application
-Name=FTB Desktop App
-Exec=/usr/bin/FTBApp
-Icon=/opt/FTBA/.install4j/FTBApp.png
-Categories=Game;