summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwardwawrzynek2020-02-05 23:47:07 -0700
committeredwardwawrzynek2020-02-05 23:47:07 -0700
commit56a2da841986cee289da04d8b9316041e6ad3e4d (patch)
treea977b62cfb563ee2eb4ae535cb58631a96ca7d8d
parente565fd5ebd2c7a779e85458ac1ae0bb1d95b2b54 (diff)
downloadaur-56a2da841986cee289da04d8b9316041e6ad3e4d.tar.gz
version 4.2c
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fae095da3f24..3c1562d8470d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Edward Wawrzynek <edward@wawrzynek.com>
pkgname=ftcfrcsimulator
-pkgver=4.2
+pkgver=4.2c
+_code_pkgver=4.2
pkgrel=2
pkgdesc="FIRST Tech Challenge and FIRST Robotics Competition Simulator"
arch=('x86_64')
@@ -11,7 +12,7 @@ depends=('gtk2')
optdepends=('openvr: For VR support')
source=(
- "${pkgname}-${pkgver}.zip::http://ftcsimulator.org/?smd_process_download=1&download_id=794"
+ "${pkgname}-${pkgver}.zip::http://ftcsimulator.org/?smd_process_download=1&download_id=816"
"ftcfrcsimulator.desktop"
"16x16.png"
"24x24.png"
@@ -22,7 +23,7 @@ source=(
"256x256.png"
)
sha1sums=(
- "f6b3ccfe3d958ebc4033eb68c3571e24bab36037"
+ "d0369e9ef765fa17656974043fd1a9236cd2a569"
"53940cf0b7bf2acb748949b8c572a89b5711ba4e"
"5b3f36d076bd653468b14f1f2afd8dd74e84ca27"
"385243f17f54ebd8dae00292fa228c8e3cf980d8"
@@ -37,15 +38,15 @@ package() {
cd "${srcdir}"
mkdir -p "${pkgdir}/usr/share/ftcfrcsimulator" "${pkgdir}/usr/bin"
# Copy data to /usr/share, set directory permissions to 755, file permissions to 644
- cp -r "FTC Simulator v${pkgver} Linux x64_Data" "${pkgdir}/usr/share/ftcfrcsimulator/"
+ cp -r "FTC Simulator v${_code_pkgver} Linux x64_Data" "${pkgdir}/usr/share/ftcfrcsimulator/"
chmod -R 0755 "${pkgdir}/usr/share/ftcfrcsimulator"
find "${pkgdir}/usr/share/ftcfrcsimulator/" -type f -exec chmod 644 {} \;
# Copy binary over
- install -Dm755 "FTC Simulator v${pkgver} Linux x64.x86_64" "${pkgdir}/usr/share/ftcfrcsimulator/FTC Simulator v${pkgver} Linux x64.x86_64"
+ install -Dm755 "FTC Simulator v${_code_pkgver} Linux x64.x86_64" "${pkgdir}/usr/share/ftcfrcsimulator/FTC Simulator v${_code_pkgver} Linux x64.x86_64"
# Put a script in /usr/bin to run app
cat <<EOF > "${pkgdir}"/usr/bin/ftcfrcsimulator
#!/bin/bash
-"/usr/share/ftcfrcsimulator/FTC Simulator v${pkgver} Linux x64.x86_64"
+"/usr/share/ftcfrcsimulator/FTC Simulator v${_code_pkgver} Linux x64.x86_64"
EOF
chmod 0755 "${pkgdir}"/usr/bin/ftcfrcsimulator
# Desktop Entry