summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwardwawrzynek2020-02-01 22:45:22 -0700
committeredwardwawrzynek2020-02-01 22:45:22 -0700
commitf76157d84c80a38d415be9e29c4c4ca8fd2a02a3 (patch)
tree88a3dc533ea586d8ec84c25efbd323c6c2f97f60
downloadaur-f76157d84c80a38d415be9e29c4c4ca8fd2a02a3.tar.gz
Version 4.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3806969bdf0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ftcfrcsimulator
+ pkgdesc = FIRST Tech Challenge and FIRST Robotics Competition Simulator
+ pkgver = 4.2
+ pkgrel = 1
+ url = http://ftcsimulator.org
+ arch = x86_64
+ license = unknown
+ depends = gtk2
+ optdepends = openvr: For VR support
+ source = ftcfrcsimulator-4.2.zip::http://ftcsimulator.org/?smd_process_download=1&download_id=794
+ sha1sums = f6b3ccfe3d958ebc4033eb68c3571e24bab36037
+
+pkgname = ftcfrcsimulator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e027cc34ffd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Edward Wawrzynek <edward@wawrzynek.com>
+
+pkgname=ftcfrcsimulator
+pkgver=4.2
+pkgrel=1
+pkgdesc="FIRST Tech Challenge and FIRST Robotics Competition Simulator"
+arch=('x86_64')
+url="http://ftcsimulator.org"
+license=('unknown')
+depends=('gtk2')
+optdepends=('openvr: For VR support')
+
+source=("${pkgname}-${pkgver}.zip::http://ftcsimulator.org/?smd_process_download=1&download_id=794")
+sha1sums=("f6b3ccfe3d958ebc4033eb68c3571e24bab36037")
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/share/ftcfrcsimulator" "${pkgdir}/usr/bin"
+ cp -r "FTC Simulator v${pkgver} Linux x64_Data" "${pkgdir}/usr/share/ftcfrcsimulator/"
+ chmod -R 0755 "${pkgdir}/usr/share/ftcfrcsimulator"
+ find "${pkgdir}/usr/share/ftcfrcsimulator/" -type f -exec chmod 644 {} \;
+ install -Dm755 "FTC Simulator v${pkgver} Linux x64.x86_64" "${pkgdir}/usr/share/ftcfrcsimulator/FTC Simulator v${pkgver} Linux x64.x86_64"
+ #ln -s "/usr/share/ftcfrcsimulator/FTC Simulator v${pkgver} Linux x64.x86_64" "${pkgdir}/usr/bin/ftcfrcsimulator"
+ cat <<EOF > "${pkgdir}"/usr/bin/ftcfrcsimulator
+#!/bin/bash
+"/usr/share/ftcfrcsimulator/FTC Simulator v${pkgver} Linux x64.x86_64"
+EOF
+ chmod 0755 "${pkgdir}"/usr/bin/ftcfrcsimulator
+}