summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessandro Pazzaglia2015-06-08 19:46:06 +0200
committerAlessandro Pazzaglia2015-06-08 19:46:06 +0200
commit7ca43f07c19d187e1462c4f8d12c35a34c3684e8 (patch)
treef29fbd0983c33bbb93b7169719f107c995c8d7d1
downloadaur-7ca43f07c19d187e1462c4f8d12c35a34c3684e8.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09538a8f579b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ftpcopy
+ pkgdesc = A simple FTP client to copy files recursively from an FTP server
+ pkgver = 0.6.7
+ pkgrel = 1
+ url = http://ohse.de/uwe/ftpcopy.html
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = http://www.ohse.de/uwe/ftpcopy/ftpcopy-0.6.7.tar.gz
+ md5sums = 78d5245970803230f0f22f0f040a58ef
+
+pkgname = ftpcopy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cf08afe1065
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alessandro Pazzaglia <jackdroido at gmail dot com>
+
+pkgname=ftpcopy
+pkgver=0.6.7
+pkgrel=1
+pkgdesc="A simple FTP client to copy files recursively from an FTP server"
+arch=('i686' 'x86_64')
+url="http://ohse.de/uwe/ftpcopy.html"
+license=('GPL2')
+source=(
+ "http://www.ohse.de/uwe/ftpcopy/${pkgname}-${pkgver}.tar.gz"
+)
+md5sums=(
+ '78d5245970803230f0f22f0f040a58ef'
+)
+
+build() {
+ cd "$srcdir/web/${pkgname}-${pkgver}"
+
+ msg "Starting make ..."
+
+ make
+}
+
+package() {
+ cd "$srcdir/web/${pkgname}-${pkgver}"
+
+ install -d -m 755 "${pkgdir}/usr/bin"
+ install -d -m 755 "${pkgdir}/usr/share/man/man1"
+
+ cp command/ftp* "${pkgdir}/usr/bin"
+ cp doc/*.1 "${pkgdir}/usr/share/man/man1"
+}