summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 11:58:44 +1000
committerJonathan Liu2015-06-19 11:58:44 +1000
commit51c8158cf50f8104a667604855616135b86561ed (patch)
tree260643942e95a92ec611d8162579ade415e78b6f
downloadaur-51c8158cf50f8104a667604855616135b86561ed.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--ftpproxy.xinetd12
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33b8b5182af4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = ftpproxy
+ pkgdesc = FTP proxy with optional access and command control and client monitoring
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = http://www.ftpproxy.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ backup = etc/xinet.d/ftpproxy
+ source = http://www.ftpproxy.org/download/ftpproxy-1.2.3.tgz
+ source = ftpproxy.xinetd
+ md5sums = c2068bc452e1d7554d3bda08030aa433
+ md5sums = 701382c974b7e4965123444038ec1897
+
+pkgname = ftpproxy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3767cb9bb0e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Jonathan Liu <net147@gmail.com>
+pkgname=ftpproxy
+pkgver=1.2.3
+pkgrel=1
+pkgdesc="FTP proxy with optional access and command control and client monitoring"
+arch=('i686' 'x86_64')
+url="http://www.ftpproxy.org/"
+license=('GPL2')
+depends=('glibc')
+backup=('etc/xinet.d/ftpproxy')
+source=("http://www.ftpproxy.org/download/${pkgname}-${pkgver}.tgz"
+ "ftpproxy.xinetd")
+md5sums=('c2068bc452e1d7554d3bda08030aa433'
+ '701382c974b7e4965123444038ec1897')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make || return 1
+ install -D -m755 src/ftp.proxy "${pkgdir}/usr/sbin/ftp.proxy" || return 1
+ install -D -m644 doc/ftp.proxy.1 "${pkgdir}/usr/share/man/man1/ftp.proxy.1" || return 1
+ install -D -m644 "${srcdir}/ftpproxy.xinetd" "${pkgdir}/etc/xinetd.d/ftpproxy"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/ftpproxy.xinetd b/ftpproxy.xinetd
new file mode 100644
index 000000000000..74a24eea17dd
--- /dev/null
+++ b/ftpproxy.xinetd
@@ -0,0 +1,12 @@
+service ftpproxy
+{
+ disable = yes
+ type = unlisted
+ socket_type = stream
+ protocol = tcp
+ wait = no
+ user = nobody
+ server = /usr/sbin/ftp.proxy
+ server_args = -e -m
+ port = 2121
+}