aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAditya Gupta2021-06-10 19:57:59 +0530
committerAditya Gupta2021-06-10 19:57:59 +0530
commit09a3c65df13fe4cb7a2320f86b2100b936d721d4 (patch)
tree305684c167377a8afcbfa23aba17494fb88c79a4
parentafa0a1a5c723132870a6e9c4b40983d9c6b595c0 (diff)
downloadaur-09a3c65df13fe4cb7a2320f86b2100b936d721d4.tar.gz
Add postinstall instructions
-rw-r--r--.SRCINFO1
-rw-r--r--.install10
-rw-r--r--PKGBUILD1
-rw-r--r--README.md7
4 files changed, 19 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7a7ee7baa765..13e2d8fbb1f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = ftxui-git
pkgver = r277.4d29dcc
pkgrel = 1
url = https://github.com/ArthurSonzogni/FTXUI
+ install = .install
arch = x86_64
license = MIT
makedepends = git
diff --git a/.install b/.install
new file mode 100644
index 000000000000..b99794f481a9
--- /dev/null
+++ b/.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "-------------------------->"
+ echo "The headers have been installed to '/usr/local/include/ftxui' and libraries to /usr/local/lib/ftxui, namely 'libcomponent.a', 'libdom.a', 'libscreen.a'"
+ echo "Don't Forget to link with the libraries :D"
+ echo "<--------------------------"
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/PKGBUILD b/PKGBUILD
index e1622bba5319..49fe2704db51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,6 +10,7 @@ depends=('cmake' 'gcc' 'ninja') # ninja is optional, just remove "-G Ninja" from
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+install='.install'
source=("${pkgname%-git}::git+https://github.com/ArthurSonzogni/FTXUI")
md5sums=('SKIP')
diff --git a/README.md b/README.md
index 713cdde84111..ac3b578c2021 100644
--- a/README.md
+++ b/README.md
@@ -5,3 +5,10 @@ Built for simple install and updation of [ftxui](https://github.com/ArthurSonzog
Just run makepkg in the directory, or see github.com/adig-pkgs/adig-pkgs how to add the custom repo to have it listed by your pacman.
+### Post Install
+
+The headers are installed to `/usr/local/include/ftxui` and libraries to /usr/local/lib/ftxui, namely `libcomponent.a`, `libdom.a`, `libscreen.a`.
+
+You will get this message from makepkg too, don't forget to link to these libraries as required :D
+
+