aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAditya Gupta2021-06-11 14:47:01 +0530
committerAditya Gupta2021-06-11 14:47:01 +0530
commit8ee45991c71a8fffd332ca56fc345a7e763a6334 (patch)
tree2445657763e548628b9cfaa8a37e62da106a8db3
parent09a3c65df13fe4cb7a2320f86b2100b936d721d4 (diff)
downloadaur-8ee45991c71a8fffd332ca56fc345a7e763a6334.tar.gz
Updated arch array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13e2d8fbb1f8..b5fbee0eb02c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,12 @@ pkgbase = ftxui-git
url = https://github.com/ArthurSonzogni/FTXUI
install = .install
arch = x86_64
+ arch = amd64
+ arch = arm64
+ arch = armhf
+ arch = i386
+ arch = ppc64el
+ arch = s390x
license = MIT
makedepends = git
depends = cmake
diff --git a/PKGBUILD b/PKGBUILD
index 49fe2704db51..a35f6b772921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Arthur Sonzogni <i_dont_know_his_mail>
+# Maintainer: Arthur Sonzogni <ftxui at gmail dot com>
pkgname=ftxui-git
pkgver=r277.4d29dcc
pkgrel=1
pkgdesc="C++ Functional Terminal User Interface"
-arch=('x86_64')
+arch=('x86_64' 'amd64' 'arm64' 'armhf' 'i386' 'ppc64el' 's390x')
url="https://github.com/ArthurSonzogni/FTXUI"
license=('MIT')
depends=('cmake' 'gcc' 'ninja') # ninja is optional, just remove "-G Ninja" from build() too, though its faster if you leave as it is
@@ -27,7 +27,7 @@ build() {
-DFTXUI_BUILD_EXAMPLES=OFF \
-DFTXUI_ENABLE_INSTALL=ON \
-DFTXUI_BUILD_TESTS=OFF \
- -DFTXUI_BUILD_DOCS=ON \
+ -DFTXUI_BUILD_DOCS=OFF \
.. -DCMAKE_BUILD_TYPE=Release
cmake --build .
@@ -35,7 +35,7 @@ build() {
check() {
cd "$srcdir/${pkgname%-git}"/build
- # Left for now, ask Arthur later
+ # make -k check
}
package() {