aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthurSonzogni2021-06-12 21:13:21 +0200
committerArthurSonzogni2021-06-13 22:00:25 +0200
commite8774d53e77c5f3f817191cf8946040163c148c7 (patch)
treed22d631ea218470d34a7f139d86c6fd88cac62d6
parent8ee45991c71a8fffd332ca56fc345a7e763a6334 (diff)
downloadaur-e8774d53e77c5f3f817191cf8946040163c148c7.tar.gz
Minor adjustments.
-rw-r--r--.SRCINFO16
-rw-r--r--.install20
-rw-r--r--PKGBUILD61
-rw-r--r--README.md34
4 files changed, 76 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5fbee0eb02c..dbc5ac6ae564 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,13 @@
pkgbase = ftxui-git
- pkgdesc = C++ Functional Terminal User Interface
- pkgver = r277.4d29dcc
+ pkgdesc = FTXUI is a C++ Functional Terminal User Interface library.
+ pkgver = r278.6f87740
pkgrel = 1
url = https://github.com/ArthurSonzogni/FTXUI
install = .install
- arch = x86_64
- arch = amd64
- arch = arm64
- arch = armhf
- arch = i386
- arch = ppc64el
- arch = s390x
+ arch = any
license = MIT
makedepends = git
- depends = cmake
- depends = gcc
- depends = ninja
+ makedepends = gcc
provides = ftxui
conflicts = ftxui
source = ftxui::git+https://github.com/ArthurSonzogni/FTXUI
diff --git a/.install b/.install
index b99794f481a9..86b1e142ae9f 100644
--- a/.install
+++ b/.install
@@ -1,7 +1,23 @@
post_install() {
echo "-------------------------->"
- echo "The headers have been installed to '/usr/local/include/ftxui' and libraries to /usr/local/lib/ftxui, namely 'libcomponent.a', 'libdom.a', 'libscreen.a'"
- echo "Don't Forget to link with the libraries :D"
+ echo "Location of the FTXUI installation:"
+ echo "- Headers : /usr/include/ftxui/"
+ echo "- Libraries : /usr/lib/ftxui/"
+ echo "- Cmake config: /usr/lib/cmake/ftxui/"
+ echo ""
+ echo "The libraries are:"
+ echo "- libscreen.a"
+ echo "- libdom.a"
+ echo "- libcomponent.a"
+ echo "Don't forget to link against them."
+ echo ""
+ echo "They corresponds to the cmake targets:"
+ echo "- ftxui::screen"
+ echo "- ftxui::dom"
+ echo "- ftxui::component"
+ echo ""
+ echo "Using cmake, FetchContent and referring to a specific hash version of"
+ echo "FTXUI is recommended instead."
echo "<--------------------------"
}
diff --git a/PKGBUILD b/PKGBUILD
index a35f6b772921..6e376e6d1c44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,42 @@
-# Maintainer: Arthur Sonzogni <ftxui at gmail dot com>
+# Maintainer: Arthur Sonzogni <sonzogniarthur+ftxui at gmail dot com>
+# Maintainer: Aditya Gupta <adityag.ug19.cs at nitp.ac.in>
pkgname=ftxui-git
-pkgver=r277.4d29dcc
+pkgver=r278.6f87740
pkgrel=1
-pkgdesc="C++ Functional Terminal User Interface"
-arch=('x86_64' 'amd64' 'arm64' 'armhf' 'i386' 'ppc64el' 's390x')
+pkgdesc="FTXUI is a C++ Functional Terminal User Interface library."
+arch=("any")
url="https://github.com/ArthurSonzogni/FTXUI"
-license=('MIT')
-depends=('cmake' 'gcc' 'ninja') # ninja is optional, just remove "-G Ninja" from build() too, though its faster if you leave as it is
-makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install='.install'
-source=("${pkgname%-git}::git+https://github.com/ArthurSonzogni/FTXUI")
-md5sums=('SKIP')
+license=("MIT")
+depends=()
+makedepends=("git" "gcc")
+provides=("ftxui")
+conflicts=("ftxui")
+install=".install"
+source=("ftxui::git+https://github.com/ArthurSonzogni/FTXUI")
+md5sums=("SKIP")
pkgver() {
- cd "$srcdir/${pkgname%-git}"
-
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/ftxui"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- mkdir -p build && cd build
- cmake -G Ninja \
- -DFTXUI_BUILD_EXAMPLES=OFF \
- -DFTXUI_ENABLE_INSTALL=ON \
- -DFTXUI_BUILD_TESTS=OFF \
- -DFTXUI_BUILD_DOCS=OFF \
- .. -DCMAKE_BUILD_TYPE=Release
-
- cmake --build .
-}
+ cd "$srcdir/ftxui"
+ mkdir -p build && cd build
+ cmake \
+ -DFTXUI_ENABLE_INSTALL=ON \
+ -DFTXUI_BUILD_EXAMPLES=OFF \
+ -DFTXUI_BUILD_TESTS=OFF \
+ -DFTXUI_BUILD_DOCS=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
-check() {
- cd "$srcdir/${pkgname%-git}"/build
- # make -k check
+ cmake --build .
}
package() {
- cd "$srcdir/${pkgname%-git}"
- cd build
- DESTDIR="$pkgdir/" cmake --install .
+ cd "$srcdir/ftxui"
+ cd build
+ DESTDIR="$pkgdir/" cmake --install .
}
diff --git a/README.md b/README.md
index ac3b578c2021..d5bce6fd254c 100644
--- a/README.md
+++ b/README.md
@@ -1,14 +1,30 @@
-## THIS IS NOT THE OFFICIAL PKGBUILD
+ftxui-git
+=========
-PKGBUILD for use on Arch by makepkg.
-Built for simple install and updation of [ftxui](https://github.com/ArthurSonzogni/FTXUI) library.
+This is the [official] [PKGBUILD] for [FTXUI] for use on [Arch Linux] via
+[makepkg].
-Just run makepkg in the directory, or see github.com/adig-pkgs/adig-pkgs how to add the custom repo to have it listed by your pacman.
+Run `makepkg` in this directory, or see [adig-pkgs] to add the custom
+repository to have this listed by your [pacman].
+Just run makepkg in the directory, or see github.com/adig-pkgs/adig-pkgs how to
+add the custom repo to have it listed by your pacman.
-### Post Install
-
-The headers are installed to `/usr/local/include/ftxui` and libraries to /usr/local/lib/ftxui, namely `libcomponent.a`, `libdom.a`, `libscreen.a`.
-
-You will get this message from makepkg too, don't forget to link to these libraries as required :D
+The headers are installed to:
+```
+/usr/local/include/ftxui
+````
+and the libraries: `libcomponent.a`, `libdom.a`, `libscreen.a` into:
+```
+/usr/local/lib/ftxui
+```
+You will get this message from makepkg too, don't forget to link to these
+libraries.
+[Arch Linux]: https://archlinux.org/
+[FTXUI]: https://github.com/ArthurSonzogni/FTXUI
+[PKGBUILD]: https://wiki.archlinux.org/title/PKGBUILD
+[adig-pkgs]: https://github.com/adig-pkgs/adig-pkgs
+[makepkg]: https://wiki.archlinux.org/title/makepkg
+[official]:https://github.com/ArthurSonzogni/FTXUI/issues/110
+[pacman]: https://wiki.archlinux.org/title/pacman