summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-01-16 12:25:03 +0100
committerKlaus Alexander Seistrup2024-01-16 12:25:03 +0100
commit5c8aac339709727090aa7d90011247a8a40cd660 (patch)
tree0505e98445ae683328f81e6153f2bf3d1166aa40
parentfe5f052b865fa3c2472fe35214446404e05c8ef7 (diff)
downloadaur-5c8aac339709727090aa7d90011247a8a40cd660.tar.gz
Make licenses field SPDX compatible
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e476e71849c8..d6e7b745623b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = fuc-bin
pkgdesc = Fast Unix Commands: Modern, performance focused unix commands (pre-compiled)
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/SUPERCILEX/fuc
arch = aarch64
arch = x86_64
- license = Apache
+ license = Apache-2.0
depends = gcc-libs
depends = glibc
provides = cpz
diff --git a/PKGBUILD b/PKGBUILD
index 6846e78a39f0..0cb289083b7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,11 @@
pkgname='fuc-bin'
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Fast Unix Commands: Modern, performance focused unix commands (pre-compiled)'
arch=('aarch64' 'x86_64')
url='https://github.com/SUPERCILEX/fuc'
-license=('Apache')
+license=('Apache-2.0') # SPDX-License-Identifier: Apache-2.0
provides=('cpz' 'fuc' 'rmz')
conflicts=('cpz' 'fuc' 'rmz' 'fuc-static-musl-bin')
replaces=('fuc-static-musl-bin')
@@ -30,13 +30,13 @@ depends=('gcc-libs' 'glibc')
package() {
# Be more verbose if standard output is a TTY
- test -t 1 && _verbose='v' || _verbose=''
+ test -t 1 && _v='v' || _v=''
for _exe in cpz rmz; do
- install "-${_verbose}Dm0755" "$_exe-$CARCH-$pkgver" "$pkgdir/usr/bin/$_exe"
+ install "-${_v}Dm0755" "$_exe-$CARCH-$pkgver" "$pkgdir/usr/bin/$_exe"
done
- install "-${_verbose}Dm0644" "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install "-${_v}Dm0644" "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
}
sha256sums_aarch64=(