summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-10-20 23:16:04 +0200
committerhaawda2017-10-20 23:16:04 +0200
commit1dae4d224af934d8f1e329e249d8ede5da69e5ee (patch)
treecaaea35468d1a4077f41be0bd11dafbdb7d6e73a
downloadaur-1dae4d224af934d8f1e329e249d8ede5da69e5ee.tar.gz
initial upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..736a76ccd96d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fuego-svn
+ pkgdesc = A collection of C++ libraries for the game of Go
+ pkgver = 2033
+ pkgrel = 1
+ url = http://fuego.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = boost-libs
+ source = fuego-code::svn+https://svn.code.sf.net/p/fuego/code/trunk/
+ md5sums = SKIP
+
+pkgname = fuego-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0301268f7b4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Auguste Pop <auguste [at] gmail [dot] com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=fuego-svn
+pkgver=2033
+pkgrel=1
+pkgdesc="A collection of C++ libraries for the game of Go"
+arch=('i686' 'x86_64')
+url="http://fuego.sourceforge.net/"
+license=('GPL')
+depends=('boost-libs')
+makedepends=('boost')
+source=("fuego-code::svn+https://svn.code.sf.net/p/fuego/code/trunk/")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-svn}-code
+ local ver="$(svnversion)"
+ printf "%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd ${pkgname%-svn}-code
+ autoreconf -i
+ CXXFLAGS="-march=native -O3 -pipe -DBOOST_FILESYSTEM_VERSION=3" \
+ LIBS="-lpthread" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-svn}-code
+ make DESTDIR=$pkgdir install
+}