summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2009-08-12 22:17:38 -0400
commit9360a2a8020f2a4550b595c8bbd41250500fc025 (patch)
tree0e87ae096ae2cce8aa4847df2093a493a5803dd2
downloadaur-9360a2a8020f2a4550b595c8bbd41250500fc025.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD52
-rw-r--r--fuhquake.desktop11
-rw-r--r--fuhquake.icobin0 -> 2238 bytes
-rw-r--r--fuhquake.install33
-rw-r--r--fuhquake.launcher5
7 files changed, 129 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..239873ca2e12
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fuhquake
+ pkgdesc = A QuakeWorld Client for Win32/Linux. You need the retail pak files to play.
+ pkgver = 0.31
+ pkgrel = 4
+ url = http://www.fuhquake.net/
+ install = fuhquake.install
+ license = GPL
+ makedepends = unzip
+ depends = libgl
+ conflicts = ezquake
+ source = fuhquake.launcher
+ source = fuhquake.install
+ source = fuhquake.desktop
+ source = fuhquake.ico
+ source = http://www.slashbunny.com/quake/fuhquake-linux-v0.31.zip
+ md5sums = c471e673a64882e3653fd953b1a3da1f
+ md5sums = 8ea170b09fe50223bb66bf93a3f160b0
+ md5sums = e64a0918e48595f4a8fb47d0e39b8c84
+ md5sums = 6a0f7982f82886210448490be5762ab0
+ md5sums = d4476cc49db638e5304ddd6cd744b62a
+
+pkgname = fuhquake
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44ac77e9f2f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+
+pkgname=fuhquake
+pkgver=0.31
+pkgrel=4
+pkgdesc="A QuakeWorld Client for Win32/Linux. You need the retail pak files to play."
+url="http://www.fuhquake.net/"
+license="GPL"
+depends=('libgl')
+makedepends=('unzip')
+conflicts=('ezquake')
+provides=()
+install=fuhquake.install
+source=('fuhquake.launcher' 'fuhquake.install' 'fuhquake.desktop' 'fuhquake.ico' \
+"http://www.slashbunny.com/quake/$pkgname-linux-v$pkgver.zip")
+md5sums=('c471e673a64882e3653fd953b1a3da1f' '8ea170b09fe50223bb66bf93a3f160b0'\
+ 'e64a0918e48595f4a8fb47d0e39b8c84' '6a0f7982f82886210448490be5762ab0'\
+ 'd4476cc49db638e5304ddd6cd744b62a')
+
+build() {
+ cd $startdir/src
+
+ # Unpack fuhQuake
+ unzip $pkgname-linux-v$pkgver.zip -d quake/
+
+ # Make binaries executable
+ chmod +x quake/fuhquake-gl.glx
+ chmod +x quake/fuhquake.svga
+ chmod +x quake/fuhquake.x11
+
+ # Move data to package directory
+ install -d $startdir/pkg/opt/
+ mv quake/ $startdir/pkg/opt/
+
+ # Make id1 Directory for pak0.pak and pak1.pak files
+ install -d $startdir/pkg/opt/quake/id1/
+
+ # Install Launcher
+ install -D -m755 $startdir/src/fuhquake.launcher \
+ $startdir/pkg/usr/bin/fuhquake
+
+ # Install Desktop
+ install -D -m644 $startdir/src/fuhquake.desktop \
+ $startdir/pkg/usr/share/applications/fuhquake.desktop
+
+ # Install Icon
+ install -D -m644 $startdir/src/fuhquake.ico \
+ $startdir/pkg/usr/share/pixmaps/fuhquake.ico
+
+ # Make Configs directory with permissions root:games so users can save configs
+ install -d -m 775 -o root -g games $startdir/pkg/opt/quake/fuhquake/configs/
+}
diff --git a/fuhquake.desktop b/fuhquake.desktop
new file mode 100644
index 000000000000..52bed1cb49cc
--- /dev/null
+++ b/fuhquake.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=FuhQuake
+GenericName=FuhQuake
+Comment=A QuakeWorld Client for Win32/Linux.
+Exec=/usr/bin/fuhquake
+Icon=/usr/share/pixmaps/fuhquake.ico
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/fuhquake.ico b/fuhquake.ico
new file mode 100644
index 000000000000..36eb32f9393f
--- /dev/null
+++ b/fuhquake.ico
Binary files differ
diff --git a/fuhquake.install b/fuhquake.install
new file mode 100644
index 000000000000..a137f577e3f1
--- /dev/null
+++ b/fuhquake.install
@@ -0,0 +1,33 @@
+
+post_install() {
+ echo ">>> You need the retail pak0.pak and pak1.pak in order to play."
+ echo ">>> Copy or symlink them to /opt/quake/id/"
+ echo ">>>"
+ echo ">>> You must also add your user to the 'games' group."
+ echo ">>>"
+ echo ">>> # gpasswd -a USERNAME games"
+ echo ">>>"
+ echo ">>> After configuring your keys and settings, save your config with"
+ echo ">>> the following command in the console: "
+ echo ">>>"
+ echo ">>> /cfg_save USERNAME"
+ echo ">>>"
+ echo ">>> Where USERNAME is what 'whoami' returns in a terminal. Everytime "
+ echo ">>> fuhQuake starts it will attempt to automatically load USERNAME.cfg"
+ echo ">>>"
+ echo ">>> You can play on any QuakeWorld servers with fuhQuake. Use a server"
+ echo ">>> browser to find games, such as XQF."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+
+$op $*
diff --git a/fuhquake.launcher b/fuhquake.launcher
new file mode 100644
index 000000000000..0c1bf09f039d
--- /dev/null
+++ b/fuhquake.launcher
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+cd "/opt/quake"
+./fuhquake-gl.glx +cfg_load `whoami` $*
+exit $?