summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-20 10:27:19 +0800
committerzxp198210052024-03-20 10:27:19 +0800
commit6448db26b2c7da7d73239e15beb93d1bca036b6f (patch)
tree43ae66c1bd03b73d3a6b894c4b18d121f1246630
parentd97aa42a0d3bc457c638b9351186ac990a3964be (diff)
downloadaur-6448db26b2c7da7d73239e15beb93d1bca036b6f.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--fukayo.sh5
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a791b27ce591..71b52346b66a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = fukayo-bin
pkgdesc = A desktop application to read your favorite manga/manhwa/manhua from your favorite websites.
pkgver = 0.13.0
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/JiPaix/Fukayo
arch = x86_64
license = MIT
makedepends = fuse2
- depends = electron24
+ depends = electron24-bin
depends = java-runtime
provides = fukayo=0.13.0
conflicts = fukayo
@@ -15,6 +15,6 @@ pkgbase = fukayo-bin
source = fukayo.sh
sha256sums = f982a5dc87485a30ac82f8c77dd400733ee192aa8d34f28fb59f06b7205a7861
sha256sums = c3fb2affb5fa8ed0b1866d379461e7e0c845ac7011f67aa7410cfe080f8d753a
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = fukayo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 653e221b4aa1..bf5a29b593c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=fukayo-bin
_appname=Fukayo
pkgver=0.13.0
_electronversion=24
-pkgrel=7
+pkgrel=8
pkgdesc="A desktop application to read your favorite manga/manhwa/manhua from your favorite websites."
arch=('x86_64')
url="https://github.com/JiPaix/Fukayo"
@@ -11,7 +11,7 @@ license=("MIT")
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
'java-runtime'
)
makedepends=(
@@ -24,11 +24,12 @@ source=(
)
sha256sums=('f982a5dc87485a30ac82f8c77dd400733ee192aa8d34f28fb59f06b7205a7861'
'c3fb2affb5fa8ed0b1866d379461e7e0c845ac7011f67aa7410cfe080f8d753a'
- '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/fukayo.sh b/fukayo.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/fukayo.sh
+++ b/fukayo.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file