summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-29 15:20:55 +0800
committerzxp198210052024-01-29 15:20:55 +0800
commit7fc507b95c841d6262b73edaf007d056a6cdfd52 (patch)
treebaa257ec7fdd3297658ac989334061889402dbde
parente4123746f6efe0c3594617a9e8804bf60390b3a2 (diff)
downloadaur-7fc507b95c841d6262b73edaf007d056a6cdfd52.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--fukayo.sh9
3 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37ba978bcbe6..2e64e782a55a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = fukayo-bin
pkgdesc = A desktop application to read your favorite manga/manhwa/manhua from your favorite websites.
pkgver = 0.13.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/JiPaix/Fukayo
arch = x86_64
license = MIT
makedepends = squashfuse
depends = electron24
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
depends = java-runtime
provides = fukayo=0.13.0
conflicts = fukayo
@@ -21,6 +18,6 @@ pkgbase = fukayo-bin
source = fukayo.sh
sha256sums = f982a5dc87485a30ac82f8c77dd400733ee192aa8d34f28fb59f06b7205a7861
sha256sums = c3fb2affb5fa8ed0b1866d379461e7e0c845ac7011f67aa7410cfe080f8d753a
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = fukayo-bin
diff --git a/PKGBUILD b/PKGBUILD
index eaf21e031477..5630743ddd95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=fukayo-bin
_appname=Fukayo
pkgver=0.13.0
_electronversion=24
-pkgrel=5
+pkgrel=6
pkgdesc="A desktop application to read your favorite manga/manhwa/manhua from your favorite websites."
arch=('x86_64')
url="https://github.com/JiPaix/Fukayo"
@@ -12,12 +12,9 @@ conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
"electron${_electronversion}"
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
'java-runtime'
)
makedepends=(
@@ -30,7 +27,7 @@ source=(
)
sha256sums=('f982a5dc87485a30ac82f8c77dd400733ee192aa8d34f28fb59f06b7205a7861'
'c3fb2affb5fa8ed0b1866d379461e7e0c845ac7011f67aa7410cfe080f8d753a'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/fukayo.sh b/fukayo.sh
index c77c53567639..0d20cddc70ca 100644
--- a/fukayo.sh
+++ b/fukayo.sh
@@ -6,12 +6,9 @@ export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file