summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-01 18:43:21 +0800
committerzxp198210052024-03-01 18:43:21 +0800
commitd97aa42a0d3bc457c638b9351186ac990a3964be (patch)
tree39726df70d909a02d55dd6e49a16b969de7f5599
parent7fc507b95c841d6262b73edaf007d056a6cdfd52 (diff)
downloadaur-d97aa42a0d3bc457c638b9351186ac990a3964be.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
-rw-r--r--fukayo.sh9
3 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e64e782a55a..a791b27ce591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,12 @@
pkgbase = fukayo-bin
pkgdesc = A desktop application to read your favorite manga/manhwa/manhua from your favorite websites.
pkgver = 0.13.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/JiPaix/Fukayo
arch = x86_64
license = MIT
- makedepends = squashfuse
+ makedepends = fuse2
depends = electron24
- depends = dbus-glib
- depends = libdbusmenu-glib
- depends = gtk2
depends = java-runtime
provides = fukayo=0.13.0
conflicts = fukayo
@@ -18,6 +15,6 @@ pkgbase = fukayo-bin
source = fukayo.sh
sha256sums = f982a5dc87485a30ac82f8c77dd400733ee192aa8d34f28fb59f06b7205a7861
sha256sums = c3fb2affb5fa8ed0b1866d379461e7e0c845ac7011f67aa7410cfe080f8d753a
- sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = fukayo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5630743ddd95..653e221b4aa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=fukayo-bin
_appname=Fukayo
pkgver=0.13.0
_electronversion=24
-pkgrel=6
+pkgrel=7
pkgdesc="A desktop application to read your favorite manga/manhwa/manhua from your favorite websites."
arch=('x86_64')
url="https://github.com/JiPaix/Fukayo"
@@ -12,13 +12,10 @@ conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
"electron${_electronversion}"
- 'dbus-glib'
- 'libdbusmenu-glib'
- 'gtk2'
'java-runtime'
)
makedepends=(
- 'squashfuse'
+ 'fuse2'
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.AppImage"
@@ -27,11 +24,11 @@ source=(
)
sha256sums=('f982a5dc87485a30ac82f8c77dd400733ee192aa8d34f28fb59f06b7205a7861'
'c3fb2affb5fa8ed0b1866d379461e7e0c845ac7011f67aa7410cfe080f8d753a'
- '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
diff --git a/fukayo.sh b/fukayo.sh
index 0d20cddc70ca..86cb3dc6a9bf 100644
--- a/fukayo.sh
+++ b/fukayo.sh
@@ -1,14 +1,15 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file