summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McCurry2016-12-02 12:26:03 -0500
committerDan McCurry2016-12-02 12:26:03 -0500
commit765120c0a867c0f0bd6f774a078b052e2baf42f6 (patch)
tree356811c960f92ff259ad79dcbbe5044e8abbdbac
parent2c93eb5821e8d4b2afd7ebcebc9658957fc9459c (diff)
downloadaur-765120c0a867c0f0bd6f774a078b052e2baf42f6.tar.gz
Fixed adding CLI arguments to execs
-rw-r--r--PKGBUILD4
-rw-r--r--fullprof-suite.install6
2 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68651763e380..e45fd1ec3ea5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
pkgname=fullprof-suite
pkgver=2016.07
-pkgrel=1
+pkgrel=2
pkgdesc="Crystallographic tools for Rietveld, profile matching & integrated intensity refinements of X-Ray and/or neutron data."
arch=('i686' 'x86_64')
url="https://www.ill.eu/sites/fullprof"
@@ -42,7 +42,7 @@ prepare() {
for i in $(find ${srcdir}/${pkgname}/. \
-maxdepth 1 -executable -type f -printf "%P "); do
- sed -e "s/\(exec.*\)/\1$i/" \
+ sed -e "s/\(exec.*\)/\1$i \"\$\@\"/" \
${srcdir}/fullprof-bin > ${srcdir}/bin/fullprof-$i
done
}
diff --git a/fullprof-suite.install b/fullprof-suite.install
index 1146a49a97bb..337e2fd72a2f 100644
--- a/fullprof-suite.install
+++ b/fullprof-suite.install
@@ -1,7 +1,7 @@
post_install() {
- echo "Programs can be launched by executing fullprof-[PROGRAM], where"
- echo "[PROGRAM] is substituted by the desired executable (e.g."
- echo "fullprof-tfp, fullprof-wfp2k, fullprof-winplotr-2006, etc.)"
+ echo " Programs can be launched by executing fullprof-[PROGRAM], where"
+ echo " [PROGRAM] is substituted by the desired executable (e.g."
+ echo " fullprof-tfp, fullprof-wfp2k, fullprof-winplotr-2006, etc.)"
}
post_upgrade() {