summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2015-06-14 10:59:09 +0200
committerlarchunix2015-06-14 10:59:09 +0200
commitf0529d58f8e49d5f93c05b9e2f749a024767fe7f (patch)
tree4234734589c54e4946925d066ed1b56bdebc98f8
downloadaur-f0529d58f8e49d5f93c05b9e2f749a024767fe7f.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..992dcfdda6a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fundamental-theme
+ pkgdesc = Fundamental BMPanel2/GTK+2.0/Openbox3/PekWM/XFWM4 Theme
+ pkgver = 20100102
+ pkgrel = 1
+ url = http://weakhead.deviantart.com/art/Fundamental-148956109
+ arch = any
+ license = GPL
+ depends = gtk-engines
+ depends = gtk-engine-murrine>=0.98.0
+ optdepends = bmpanel2: BMPanel2 theme
+ optdepends = openbox: Openbox theme
+ optdepends = pekwm: PekWM theme
+ optdepends = xfwm4: XFWM4 theme
+ source = http://orig00.deviantart.net/1690/f/2010/002/8/8/fundamental_by_weakhead.zip
+ md5sums = 2a6db561c63c00149a75e2c890102174
+
+pkgname = fundamental-theme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b4dce828b4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=fundamental-theme
+pkgver=20100102
+pkgrel=1
+pkgdesc="Fundamental BMPanel2/GTK+2.0/Openbox3/PekWM/XFWM4 Theme"
+arch=('any')
+url="http://weakhead.deviantart.com/art/Fundamental-148956109"
+license=('GPL')
+depends=('gtk-engines' 'gtk-engine-murrine>=0.98.0')
+optdepends=('bmpanel2: BMPanel2 theme'
+ 'openbox: Openbox theme'
+ 'pekwm: PekWM theme'
+ 'xfwm4: XFWM4 theme')
+source=("http://orig00.deviantart.net/1690/f/2010/002/8/8/fundamental_by_weakhead.zip")
+md5sums=('2a6db561c63c00149a75e2c890102174')
+
+prepare() {
+ cd Fundamental
+
+ # Purge backup files
+ find . -type f -name '*~' -print0 | xargs -0r rm
+}
+
+package() {
+ cd Fundamental
+
+ # BMPanel2 Theme
+ mkdir -p "$pkgdir"/usr/share/bmpanel2/themes
+ cp -a BMPanel2/Fundamental "$pkgdir"/usr/share/bmpanel2/themes
+
+ # GTK+2.0/Openbox3/XFWM4 Themes
+ mkdir -p "$pkgdir"/usr/share/themes
+ cp -a GTK/Fundamental "$pkgdir"/usr/share/themes
+
+ # PekWM Theme
+ mkdir -p "$pkgdir"/usr/share/pekwm/themes
+ cp -a PekWM/Fundamental "$pkgdir/"usr/share/pekwm/themes
+}
+
+# vim: set ft=sh ts=4 sw=4 noet: