summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheJackiMonster2021-02-14 23:05:07 +0100
committerTheJackiMonster2021-02-14 23:05:07 +0100
commit1d14bec36077dee5566a35bcf12b0bf56840a08c (patch)
tree49f2eb8cab514fcb6f30a8414dbcfa703cad638f
parent691eeb0a003d5dbe5b8f8e496e5f0b432427efb5 (diff)
downloadaur-1d14bec36077dee5566a35bcf12b0bf56840a08c.tar.gz
fixed portability problem with work-around
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 371c656e5df3..a80cdc96851c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = funemustation-git
pkgdesc = A simple but elegant launcher of emulators and pc games
pkgver = r15.c8111e8
- pkgrel = 1
+ pkgrel = 2
url = https://dannygaray60.itch.io/funemustation-launcher
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 009d8580fa70..9a8031046a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=funemustation-git
_name=funemustation
_export=FunEmuStation_Launcher
pkgver=r15.c8111e8
-pkgrel=1
+pkgrel=2
pkgdesc="A simple but elegant launcher of emulators and pc games"
url="https://dannygaray60.itch.io/funemustation-launcher"
depends=('libxcursor' 'libxinerama' 'freetype2' 'alsa-lib' 'libxrandr' 'libxi' 'libglvnd')
@@ -26,7 +26,10 @@ build() {
mkdir -p "bin"
echo "#!/bin/sh" > "bin/${_name}"
- echo "cd /usr/share/$_name" >> "bin/${_name}"
+ echo "mkdir -p ~/.local/share/${_name}/fes_data" >> "bin/${_name}"
+ echo "cp /usr/share/${_name}/${_export}.x86_64 ~/.local/share/${_name}/${_export}.x86_64" >> "bin/${_name}"
+ echo "if [ ! -h test ]; then ln -s /usr/share/${_name}/${_export}.pck ~/.local/share/${_name}/${_export}.pck; fi" >> "bin/${_name}"
+ echo "cd ~/.local/share/${_name}" >> "bin/${_name}"
echo "./${_export}.x86_64" >> "bin/${_name}"
godot --no-window --path "." --export "Linux/X11" "bin/${_export}.x86_64"