summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheJackiMonster2021-01-07 00:11:19 +0100
committerTheJackiMonster2021-01-07 00:11:19 +0100
commit2ffe953f0a496216dd28cdc8029262ff3fc7859e (patch)
treefc20516e7c3a917c8ed34f2edc7338b0f8d75189
downloadaur-2ffe953f0a496216dd28cdc8029262ff3fc7859e.tar.gz
Initial commit
Signed-off-by: TheJackiMonster <thejackimonster@gmail.com>
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9f7afb2df50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = funemustation-git
+ pkgdesc = A simple but elegant launcher of emulators and pc games
+ pkgver = r9.407c919
+ pkgrel = 1
+ url = https://dannygaray60.itch.io/funemustation-launcher
+ arch = any
+ license = GPL3
+ makedepends = godot
+ makedepends = git
+ provides = funemustation
+ source = git+https://github.com/dannygaray60/funemustation.git
+ sha256sums = SKIP
+
+pkgname = funemustation-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3eefc59e96b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Tobias Frisch <thejackimonster@gmail.com>
+
+pkgname=funemustation-git
+_name=funemustation
+_export=FunEmuStation_Launcher
+pkgver=r9.407c919
+pkgrel=1
+pkgdesc="A simple but elegant launcher of emulators and pc games"
+url="https://dannygaray60.itch.io/funemustation-launcher"
+depends=()
+makedepends=('godot' 'git')
+optdepends=()
+license=('GPL3')
+arch=('any')
+source=("git+https://github.com/dannygaray60/${_name}.git")
+sha256sums=('SKIP')
+provides=('funemustation')
+
+pkgver() {
+ cd ${srcdir}/${_name}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/${_name}
+
+ mkdir -p "bin"
+ echo "#!/bin/sh" > "bin/${_name}"
+ echo "cd /usr/share/$_name" >> "bin/${_name}"
+ echo "./${_export}.x86_64" >> "bin/${_name}"
+
+ godot-headless --no-window --path "." --export "Linux/X11" "bin/${_export}.x86_64"
+}
+
+package() {
+ cd ${srcdir}/${_name}
+
+ install -Dm755 "bin/${_export}.x86_64" "$pkgdir/usr/share/$_name/${_export}.x86_64"
+ install -Dm644 "bin/${_export}.pck" "$pkgdir/usr/share/$_name/${_export}.pck"
+ install -Dm755 "bin/${_name}" "$pkgdir/usr/bin/${_name}"
+}
+