summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2018-10-18 14:02:44 +0200
committerSeverin Glöckner2018-10-18 14:02:44 +0200
commit3ce78673dc84a92c817a3042832f93c06bbcda2f (patch)
treef5a451ffe03de037c04c68d89cbb307999dc32c7
parent04cf8334533d1f8d492e7cbf6d6fbb0a3bb3ee5e (diff)
downloadaur-3ce78673dc84a92c817a3042832f93c06bbcda2f.tar.gz
PKGBUILD tweaks
show correct license move docs to standard location move boost to makedepends
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 728ded820166..784d8422fb22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,15 @@ pkgrel=11
pkgdesc="3D game about collecting mushrooms in outerspace"
arch=('i686' 'x86_64')
url="http://funguloids.sourceforge.net/"
-license=('GPL')
-makedepends=('python')
-depends=('boost' 'ogre>=1.10' 'ois>=0.7' 'freealut' 'lua51' 'libogg' 'libvorbis' 'libmad')
+license=('ZLIB')
+makedepends=('boost' 'python')
+depends=('boost-libs' 'ogre>=1.10' 'ois>=0.7' 'freealut' 'lua51' 'libogg' 'libvorbis' 'libmad')
source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-linux-${_realver}.tar.bz2
funguloids.desktop
funguloids-alc_error.patch
funguloids-gcc44.patch
- funguloids-ogre_1.6.patch funguloids-strcmp.patch
+ funguloids-ogre_1.6.patch
+ funguloids-strcmp.patch
size_chunks_reverse.patch
mpak.py
funguloids-lua.patch
@@ -133,4 +134,11 @@ package() {
# install desktop file
install -Dm644 "${srcdir}/funguloids.desktop" \
"${pkgdir}/usr/share/applications/funguloids.desktop"
+
+ # install license file
+ install -Dm644 "${srcdir}/${pkgname}/COPYING" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # use default location for docs
+ mv "${pkgdir}/usr/share/docs" "${pkgdir}/usr/share/doc"
}