summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2020-09-10 01:07:38 +0100
committergetzze2020-09-10 01:07:38 +0100
commit3363ac7ea346a501479abf3e04722033869f9922 (patch)
tree824fd68ce2e8898fad1b17f96f5e169cefd73771
parent75b002025da375a80af7b2df78af4dc4a1f4dea0 (diff)
downloadaur-3363ac7ea346a501479abf3e04722033869f9922.tar.gz
update 1.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD16
2 files changed, 20 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b18b1a6babf1..184eedd3b830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = funkwhale
pkgdesc = A self-hosted, modern free and open-source music server, heavily inspired by Grooveshark.
- pkgver = 0.21
- pkgrel = 2
+ pkgver = 1.0
+ pkgrel = 1
url = https://funkwhale.audio/
install = funkwhale.install
arch = any
@@ -13,7 +13,7 @@ pkgbase = funkwhale
depends = python
depends = ipython
depends = mod_xsendfile
- depends = python-django>=3.0.5
+ depends = python-django
depends = python-django-environ
depends = python-pillow
depends = python-django-allauth
@@ -38,7 +38,7 @@ pkgbase = funkwhale
depends = python-raven
depends = python-magic-git
depends = python-django-channels
- depends = python-django-channels-redis
+ depends = python-django-channels-redis>=3
depends = uvicorn
depends = gunicorn
depends = python-cryptography
@@ -51,7 +51,6 @@ pkgbase = funkwhale
depends = python-pydub
depends = python-pyld
depends = python-aiohttp
- depends = python-autobahn
depends = python-django-oauth-toolkit
depends = python-django-storages
depends = python-boto3
@@ -61,23 +60,24 @@ pkgbase = funkwhale
depends = python-service-identity
depends = python-markdown
depends = python-bleach
- depends = python-feedparser
+ depends = python-feedparser-dev>=6
+ depends = python-watchdog
optdepends = apache: to use the Apache web server
optdepends = certbot-apache: for the server to be accessible from outside
optdepends = nginx: to use nginx web server
optdepends = python-daphne: an alternative web server
- source = funkwhale-0.21-api.zip::https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/0.21/download?job=build_api
- source = funkwhale-0.21-front.zip::https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/0.21/download?job=build_front
- source = https://dev.funkwhale.audio/funkwhale/funkwhale/raw/0.21/deploy/funkwhale_proxy.conf
- source = https://dev.funkwhale.audio/funkwhale/funkwhale/raw/0.21/deploy/nginx.template
+ source = funkwhale-1.0-api.zip::https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/1.0/download?job=build_api
+ source = funkwhale-1.0-front.zip::https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/1.0/download?job=build_front
+ source = https://dev.funkwhale.audio/funkwhale/funkwhale/raw/1.0/deploy/funkwhale_proxy.conf
+ source = https://dev.funkwhale.audio/funkwhale/funkwhale/raw/1.0/deploy/nginx.template
source = funkwhale-beat.service
source = funkwhale-worker.service
source = funkwhale-server.service
source = apache-funkwhale.conf
source = env-template
source = funkwhale.service
- sha256sums = 0ffb4c97a2f5bc0adbda070f5300e5af76dfda81489dfa03be3e9a78cd4139b3
- sha256sums = d412b9bf0bb57d48332c6a6ab2f14c6d8e4dc792421ed4077f65550c58ecd754
+ sha256sums = d8a91f57aebd218c30c2bc08a4c665fe25a7906ae95b07c07f5296e19f3d5844
+ sha256sums = f062d7485325a78f08afaf2c641d8616e983d82d11dfc1e656cbc09a113c4202
sha256sums = 2906a075b41dcd2375c601482cb5a00e42cb87c613012b176c570d77918afbf2
sha256sums = f56a2e8947809db4325a6c65141f6eb87e7428cc0e5a57032fc7ce050bf396fa
sha256sums = a964a7802252d20a3319e2131c27ec307ad4f454921c2db31971c080150d7c9b
diff --git a/PKGBUILD b/PKGBUILD
index 81acadf440ca..fbcdedfd5cbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: getzze <getzze at gmail dot com>
pkgname=funkwhale
-pkgver=0.21
-pkgrel=2
+pkgver=1.0
+pkgrel=1
pkgdesc="A self-hosted, modern free and open-source music server, heavily inspired by Grooveshark."
arch=(any)
url="https://funkwhale.audio/"
@@ -14,7 +14,7 @@ optdepends=('apache: to use the Apache web server'
depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'ipython'
'mod_xsendfile'
- 'python-django>=3.0.5'
+ 'python-django'
'python-django-environ'
'python-pillow'
'python-django-allauth'
@@ -39,7 +39,7 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-raven'
'python-magic-git'
'python-django-channels'
- 'python-django-channels-redis'
+ 'python-django-channels-redis>=3'
'uvicorn'
'gunicorn'
'python-cryptography'
@@ -52,7 +52,6 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-pydub'
'python-pyld'
'python-aiohttp'
- 'python-autobahn'
'python-django-oauth-toolkit'
'python-django-storages'
'python-boto3'
@@ -62,7 +61,8 @@ depends=('ffmpeg' 'libjpeg' 'postgresql' 'python'
'python-service-identity'
'python-markdown'
'python-bleach'
- 'python-feedparser'
+ 'python-feedparser-dev>=6'
+ 'python-watchdog'
)
makedepends=(git)
_source_api="https://dev.funkwhale.audio/funkwhale/funkwhale/-/jobs/artifacts/${pkgver}/download?job="
@@ -78,8 +78,8 @@ source=("${pkgname}-${pkgver}-api.zip::${_source_api}build_api"
"env-template"
"funkwhale.service"
)
-sha256sums=('0ffb4c97a2f5bc0adbda070f5300e5af76dfda81489dfa03be3e9a78cd4139b3'
- 'd412b9bf0bb57d48332c6a6ab2f14c6d8e4dc792421ed4077f65550c58ecd754'
+sha256sums=('d8a91f57aebd218c30c2bc08a4c665fe25a7906ae95b07c07f5296e19f3d5844'
+ 'f062d7485325a78f08afaf2c641d8616e983d82d11dfc1e656cbc09a113c4202'
'2906a075b41dcd2375c601482cb5a00e42cb87c613012b176c570d77918afbf2'
'f56a2e8947809db4325a6c65141f6eb87e7428cc0e5a57032fc7ce050bf396fa'
'a964a7802252d20a3319e2131c27ec307ad4f454921c2db31971c080150d7c9b'