summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElias Riedel Gårding2019-04-19 22:16:54 +0200
committerElias Riedel Gårding2019-04-19 22:16:54 +0200
commit05ea82dec485a53dc8e3995b3c93e3a1113a70d3 (patch)
tree7ce34617a9c9f07e9127352b26c16a571d96657e
downloadaur-05ea82dec485a53dc8e3995b3c93e3a1113a70d3.tar.gz
First version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
-rw-r--r--funky-git.install5
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b918b35bc09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = funky-git
+ pkgdesc = Create directory-specific shell functions
+ pkgver = v3.3.1.r3.g4b710b1
+ pkgrel = 1
+ url = https://github.com/bbugyi200/funky
+ install = funky-git.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-setuptools
+ depends = python-future
+ depends = python-pygments
+ depends = python-six
+ provides = funky
+ conflicts = funky
+ source = git+https://github.com/bbugyi200/funky.git
+ md5sums = SKIP
+
+pkgname = funky-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..244ac9ea62a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Elias Riedel Gårding <eliasrg@kth.se>
+# Author: Bryan Bugyi <bryanbugyi34@gmail.com>
+pkgname=funky-git
+pkgver=v3.3.1.r3.g4b710b1
+pkgrel=1
+pkgdesc="Create directory-specific shell functions"
+arch=('any')
+url="https://github.com/bbugyi200/funky"
+license=('MIT')
+depends=('python-setuptools' 'python-future' 'python-pygments' 'python-six')
+makedepends=('git')
+provides=('funky')
+conflicts=('funky')
+install=funky-git.install
+source=("git+https://github.com/bbugyi200/funky.git")
+md5sums=('SKIP')
+
+# --- Packaging notes ---
+# usr/bin/funky imports pkg_resources, so python-setuptools is in depends, not
+# makedepends, following the Python packaging guidelines
+
+pkgver() {
+ cd "${pkgname%%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+build() {
+ cd "${pkgname%%-git}"
+ python setup.py build
+}
+
+
+package() {
+ cd "${pkgname%%-git}"
+
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ cp LICENSE "$pkgdir/usr/share/licenses/${pkgname}"
+
+ mkdir -p "$pkgdir/usr/share/doc/${pkgname%%-git}"
+ cp README.md "$pkgdir/usr/share/doc/${pkgname%%-git}"
+
+ # Set XDG_DATA_HOME to avoid installing funky.sh in $HOME/.local/share
+ XDG_DATA_HOME=/usr/share/funky python setup.py install \
+ --root="$pkgdir/" --optimize=1 --skip-build
+}
diff --git a/funky-git.install b/funky-git.install
new file mode 100644
index 000000000000..4e21c685cc61
--- /dev/null
+++ b/funky-git.install
@@ -0,0 +1,5 @@
+post_install() {
+ cat <<EOF
+For shell integration, add "source /usr/share/funky/funky.sh" to your .zshrc or .bashrc.
+EOF
+}