summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2013-08-09 17:10:40 +0200
committerHyacinthe Cartiaux2015-06-09 00:18:49 +0200
commiteb7789fe88b2896b55bb6ef4e13abe85fff30e92 (patch)
tree7ed1d68f02efa57b25dc0420aac0ec689a41aec8
downloadaur-eb7789fe88b2896b55bb6ef4e13abe85fff30e92.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4f5624dda4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = funny-manpages
+ pkgdesc = A set of miscellaneous humorous manpages (don't take them too seriously!).
+ pkgver = 1.3
+ pkgrel = 5
+ url = http://debian.org/
+ arch = any
+ license = custom
+ source = http://ftp.debian.org/debian/pool/main/f/funny-manpages/funny-manpages_1.3.orig.tar.gz
+ source = http://ftp.debian.org/debian/pool/main/f/funny-manpages/funny-manpages_1.3-5.diff.gz
+ md5sums = bed1deef82218d42fb230a2176a11ed4
+ md5sums = d7bccce54fb400de443fe6ff15bba940
+
+pkgname = funny-manpages
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2694f45a2dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux at free.fr>
+# Contributor: Arkham <arkham at archlinux dot us>
+# Contributor: StaCk <proc.null at gmail dot com>
+
+pkgname=funny-manpages
+pkgver=1.3
+pkgrel=5
+pkgdesc="A set of miscellaneous humorous manpages (don't take them too seriously!)."
+arch=('any')
+url="http://debian.org/"
+license=('custom')
+source=(http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_$pkgver.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_$pkgver-5.diff.gz)
+md5sums=('bed1deef82218d42fb230a2176a11ed4'
+ 'd7bccce54fb400de443fe6ff15bba940')
+
+build() {
+ # Apply the patch
+ cd $srcdir
+ patch -p0 -i ${pkgname}_$pkgver-5.diff || return 1
+
+ # Rename the manpages to man6
+ cd $pkgname-$pkgver.orig
+ for f in *.[0-57-9]fun ; do
+ mv $f ${f/.?fun/.6fun}
+ done
+}
+
+package() {
+ install -d $pkgdir/usr/share/man/man6/
+ install -m 644 $srcdir/$pkgname-$pkgver.orig/*.6fun $pkgdir/usr/share/man/man6/
+
+ # Install the license
+ install -Dm 644 $srcdir/$pkgname-$pkgver.orig/debian/copyright $pkgdir/usr/share/licenses/$pkgname/copyright
+}